LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2011, 01:58 AM   #1
NabiVakili
LQ Newbie
 
Registered: Feb 2011
Posts: 13

Rep: Reputation: 6
Unhappy php_gd.dll not found in php.ini !!


I installed PHP successfully on my Ubuntu 10.04
I checked the installation with phpinfo() and saw that the GD has been installed successfully :

GD Support enabled
GD Version 2.0
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.3.11
T1Lib Support enabled
GIF Read Support enabled
GIF Create Support enabled
JPEG Support enabled
libJPEG Version 6b
PNG Support enabled
libPNG Version 1.2.42
WBMP Support enabled

but gd functions appears to be not enabled on my server, so I tried to change the ";extension=php_gd.dll" line in php.ini and remove the ";" but the php.ini did not contain this line!

What should I do now? Is there any missing part?
Please help me.
thanks
 
Old 02-22-2011, 03:29 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,882

Rep: Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608
Hi,

It looks like gd support is installed in your php. Note that .dll is a windows dynamic link library, so it's not needed in linux.
Could you give more details about what is not working
 
Old 02-23-2011, 03:45 AM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by bathory View Post
Hi,

It looks like gd support is installed in your php. Note that .dll is a windows dynamic link library, so it's not needed in linux.
Could you give more details about what is not working

Or, in other words, where did the guys php.ini come from!? :}



Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] php.ini.rpmsave instead of php.ini ilvista Linux - Server 3 02-01-2011 05:39 PM
PHP php_gd.dll error. keysorsoze Linux - Software 3 02-08-2007 10:09 PM
php.ini-dist to php.ini lord-fu Programming 10 05-02-2006 06:24 PM
php5 apache2 mysql4 don't work, php does not seem to read php.ini atom Linux - Software 5 03-24-2005 12:05 PM
Error: "A required .DLL file, CYGPCRE -0.DLL, was not found" when using man dipperdan Linux - Newbie 2 04-28-2004 04:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration