LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   PHP5.0.0RC3 on Fedora Core 2 (https://www.linuxquestions.org/questions/linux-newbie-8/php5-0-0rc3-on-fedora-core-2-a-195263/)

aalbre 06-19-2004 06:02 AM

PHP5.0.0RC3 on Fedora Core 2
 
Hi.

I'm trying to install/build PHP5.0.0RC3 on my Fedora Core 2 installation...

I have installed the httpd-devel package (with up2date) and I have copied the header files in the include folder in "mysqlxxxx.tar.gz" to /usr/include/mysql.

Then, in the folder where I untared the PHP5.0.0RC3.tar.gz file, I'm trying to run: ./configure --with-mysql --with-apxs2 --with-zlib-dir=/usr/lib

After a while it stops with the following error message:
configure: error: mysql configure failed. Please check config.log for more information.

What is wrong? Please help.
:Pengy:


aalbre.
:newbie:

LLS 10-01-2004 01:58 PM

Try stopping the mysqld service befor you configure or make php5.

btmiller 10-01-2004 02:56 PM

I've never had to stop MySQL before compiling a new PHP, and there shouldn't be any way a running MySQL process can interfere with the configuration. Did you check the config.log like the message says? What does it say?

LLS 10-02-2004 07:57 PM

I don't know if you have solved yet, but I just did a mysql and then php installation and got the same error as you using "--with-mysql" and this has happened twice now, when I change to" --with-MySQL" the configuration finds the header files and is successfull. Good luck.


All times are GMT -5. The time now is 05:54 PM.