LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   php-mysql-apache (https://www.linuxquestions.org/questions/linux-newbie-8/php-mysql-apache-82494/)

spako 08-16-2003 06:48 AM

php-mysql-apache
 
hi

i am trying to get php working with mysql for an apache web server.

I am using an SSH connection to make modifications and have RedHat 7.3 installed.I am using rpm's not source.

I also have MySQL 4.0.14 installed, apache 1.3.27 and php 4.1.2.

I tried to install php-mysql-4.1.2-7 but it gave me this:
# rpm -i php-mysql-4.1.2-7.i386.rpm
error: failed dependencies:
libmysqlclient.so.10 is needed by php-mysql-4.1.2-7

So i installed MySQL-shared-4.0.14 which has libmysqlclient.so.12 but still the same error when tring to install php-mysql.

I have tried to install a higher version of php but that requires a newer version of glibc. I cant seem to get glibc upgraded at all.

the reason why this all started is because php gave my an error:
Fatal Error mysql_connect() unknown function
or something like that

please help i am a linux newbie:confused:

spako 08-16-2003 08:05 AM

i solved the problem myself
i had to load old libraries with MySQL-shared-compat
then i could install php-mysql

and now i can access mysql via php/apache!!!


All times are GMT -5. The time now is 04:33 AM.