LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   PHP install problem on Debian (https://www.linuxquestions.org/questions/linux-newbie-8/php-install-problem-on-debian-302284/)

nevarlen 03-16-2005 09:19 AM

PHP install problem on Debian
 
I am running on Debian 3.x, apache 2.xx
Everything was just fine until I upgraded to apache 2.xx from 1.3. I had a working php&apache. After the upgrade, I tried adding php to apache, but I never got them working. Then I decided to upgrade php 4.3 to php 5.0 thinking that newer versions of both would work, that failed too.
Just to give you as much info as possible, before upgrading I removed all of the php folders to do fresh install.
All of my installation attempts had mysql, apsx and imap included. While installing php5 and php4(later), script never created a make file, configure script ended by complaining about libxml package. I checked my libxml version, found that it was 2.x, which should be okay. Anyhow, last thing I tried was installing it through debain apt-get method. Apt-get did not have php5, so I went ahead and installed php4 again. Installation was not successful, errors I get::::
PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/20020429/
imap.so' - /usr/lib/php4/20020429/imap.so: cannot open shared object file: No su
ch file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/20020429/
mysql.so' - /usr/lib/php4/20020429/mysql.so: cannot open shared object file: No
such file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/20020429/
ldap.so' - /usr/lib/php4/20020429/ldap.so: cannot open shared object file: No su
ch file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/20020429/
curl.so' - /usr/lib/php4/20020429/curl.so: cannot open shared object file: No su
ch file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/20020429/
odbc.so' - /usr/lib/php4/20020429/odbc.so: cannot open shared object file: No su
ch file or directory in Unknown on line 0
PHP 4.3.4 (cli) (built: Mar 27 2004 08:04:22)
Copyright (c) 1997-2003 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies


Last thing, if you noticed the version info it says the package was built on Mar 27 2004, which I find it to be odd.
Also, I am sure that I have these modules but php just does not like them.
I am getting ready to give another shot at reinstalling php again, could you all please tell me what I should do prior to anything.
I would like to remove any existing php package and install a new one that would work with apache 2 and mysql, at least.
Thanks very much in advance..

Mara 03-16-2005 04:21 PM

The errors are not errors, only warnings. They may be here, but it's better to get rid of them...Please check if you really have them in the exact location the messages mention.
Also, which packages have you installed?


All times are GMT -5. The time now is 11:21 PM.