-   Linux - Newbie (
-   -   php error failed to open stream (

mhatre kedar 03-20-2005 03:18 PM

php error failed to open stream
i just compiled and installed php-4.3.10 on apache 1.3.3
and included include_path='.:/usr/local/lib/php'
in php.ini as suggested while compiling

however i get the following message while trying phpinfo();

Warning: Unknown(/www/htdocs/1.php): failed to open stream: Permission denied in Unknown on line 0

Warning: (null)(): Failed opening '/www/htdocs/1.php' for inclusion (include_path='.:/usr/local/lib/php/') in Unknown on line 0

i also tried on apache 2.0 and php-5
i am running fedora core 3
also tried configtest but nothing in that too...
please help

also when i remove include_path in php.ini
it gives same error

and changing include_path also changes the path in servers output i.e for inclusion(inclue_path="new_path")

t3gah 03-20-2005 03:39 PM

Are you following the HOWTO's at The Linux Documentation Project?

david_ross 03-20-2005 03:47 PM

What are the permissions on 1.php - is it readable by the webserver?

All times are GMT -5. The time now is 01:28 PM.