LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2004, 07:49 PM   #1
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Rep: Reputation: 15
php doesn't work


Hi, I've just installed php on my Slackware 9.0:
----
installpkg php-4.3.4-i486-1.tgz
----

and I have problem, when I'm running php:
-----------
# php
php: error while loading shared libraries: libmm.so.13: cannot open shared object file: No such file or directory
-----------
where can I get this lost library from?
 
Old 01-21-2004, 07:56 PM   #2
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Original Poster
Rep: Reputation: 15
I have installed mm-1.3.0 from source, right now & there is this library libmm.so.13 but after 'make install' my php still doesn't find this lib
 
Old 01-21-2004, 08:05 PM   #3
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Original Poster
Rep: Reputation: 15
$ find /usr/local/lib -name libmm.so.13
/usr/local/lib/libmm.so.13

$ cat /etc/ld.so.conf
/usr/local/lib
/usr/X11R6/lib
/usr/i386-slackware-linux/lib
/opt/kde/lib
/usr/lib/qt/lib
 
Old 01-21-2004, 08:14 PM   #4
drenal
Member
 
Registered: Dec 2003
Location: Poland
Distribution: slackware current
Posts: 53

Original Poster
Rep: Reputation: 15
all right guys, I ve just solved this problem, just type 'ldconfig'

see you to next problem

YO
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Get php to work? ahsiii Linux - Software 3 11-29-2005 07:02 AM
Getting PHP to work..... wacki Programming 4 08-24-2005 06:38 PM
php5 apache2 mysql4 don't work, php does not seem to read php.ini atom Linux - Software 5 03-24-2005 12:05 PM
getting PHP to work...please help! rudini Linux - Software 12 03-24-2005 06:44 AM
Apache Mysql Php: mysql with php doesn't work breakerfall Linux - Networking 6 12-27-2003 09:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration