LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2010, 11:30 AM   #1
heberg21
LQ Newbie
 
Registered: Jan 2010
Posts: 9

Rep: Reputation: 0
Permissions with DVD-RAM


Hello,

I have an Ubuntu 9.10 x86-64 desktop system with a multi-recorder optical drive that supports DVD-RAM.

When I login as root and I insert a DVD-RAM disk (with data) it mounts normally as a any other disk. The problem I am having is that when I login as normal user (an admin user) I do not have permission to even read the content, and thus, it does not automount. How can I fix this? Thanks in advance.
 
Old 02-15-2010, 11:38 AM   #2
irmin
Member
 
Registered: Jan 2010
Location: the universe
Distribution: Slackware (modified), Slackware64 (modified), openSuSE (modified)
Posts: 342

Rep: Reputation: 62
Perhaps the DVD is mounted with a wrong umask or uid/gid values. Try the following:

Code:
umount /dev/<your dvd-device>
mount /dev/<your dvd-device> /mnt -o umask=0777
or
Code:
umount /dev/<your dvd-device>
mount /dev/<your dvd-device> /mnt -o uid=<your uid>,gid=<your gid>
<your dvd-device> should be sr0 in most modern cases. In the last case you will be the owner of all files on the disk, which the former commands will not clear the permissions for the files.
 
Old 02-15-2010, 11:48 AM   #3
heberg21
LQ Newbie
 
Registered: Jan 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by irmin View Post
Perhaps the DVD is mounted with a wrong umask or uid/gid values. Try the following:

Code:
umount /dev/<your dvd-device>
mount /dev/<your dvd-device> /mnt -o umask=0777
or
Code:
umount /dev/<your dvd-device>
mount /dev/<your dvd-device> /mnt -o uid=<your uid>,gid=<your gid>
<your dvd-device> should be sr0 in most modern cases. In the last case you will be the owner of all files on the disk, which the former commands will not clear the permissions for the files.
I am not sure how to get my gid or uid (?). Moreover, it works fine when I put a CD-ROM or a DVD movie disk in, this issue is only happening with DVD-RAM and DVD+RW discs.

Last edited by heberg21; 02-15-2010 at 11:50 AM.
 
Old 02-15-2010, 12:09 PM   #4
irmin
Member
 
Registered: Jan 2010
Location: the universe
Distribution: Slackware (modified), Slackware64 (modified), openSuSE (modified)
Posts: 342

Rep: Reputation: 62
uid=user id, gid=group id. They can also be replaced by symbolic names.

Try the following:
Insert the disk.
Get root and unmount the disk: "umount /dev/sr0"
Then mount it by trying "mount /dev/sr0 /mnt -o uid=<your-login-name>,gid=users"
Open a shell and try to access /mnt. If you can, then the problem is due to wrong mount parameters.
If not, try to post some lines of the output of "ls -l /mnt" (the filenames can be removed, if you do not want to show them here).
 
Old 02-15-2010, 12:22 PM   #5
heberg21
LQ Newbie
 
Registered: Jan 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by irmin View Post
uid=user id, gid=group id. They can also be replaced by symbolic names.

Try the following:
Insert the disk.
Get root and unmount the disk: "umount /dev/sr0"
Then mount it by trying "mount /dev/sr0 /mnt -o uid=<your-login-name>,gid=users"
Open a shell and try to access /mnt. If you can, then the problem is due to wrong mount parameters.
If not, try to post some lines of the output of "ls -l /mnt" (the filenames can be removed, if you do not want to show them here).
This time I was able to access it through /mnt, but now the dilemma is how to get it to mount as a normal optical disk, automatically upon insertion, without having to issue any commands.
Currently my /etc/fstab has this:
/dev/sr0 /media/cdrom0 user,udf,iso9660 user,noauto,exec,utf8 0 0

Last edited by heberg21; 02-15-2010 at 12:25 PM.
 
Old 02-15-2010, 02:15 PM   #6
irmin
Member
 
Registered: Jan 2010
Location: the universe
Distribution: Slackware (modified), Slackware64 (modified), openSuSE (modified)
Posts: 342

Rep: Reputation: 62
Make the options permanent:
Code:
/dev/sr0 /media/cdrom0 user,udf,iso9660 user,noauto,exec,utf8,uid=<your login>,gid=users,umask=0666 0 0
You can probably omit uid=...,when specifying umask
 
Old 02-15-2010, 03:50 PM   #7
heberg21
LQ Newbie
 
Registered: Jan 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by irmin View Post
Make the options permanent:
Code:
/dev/sr0 /media/cdrom0 user,udf,iso9660 user,noauto,exec,utf8,uid=<your login>,gid=users,umask=0666 0 0
You can probably omit uid=...,when specifying umask
I tried the above and still did not work, but then changed it to:
Code:
/dev/sr0      /media/cdrom0   udf,iso9660 user,noauto,exec,utf8,gid=cdrom 0       0
And that did the trick.
Thank you very much, you pointed me in the right direction.

Last edited by heberg21; 02-15-2010 at 05:04 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set permissions fro RAM usage per user in SUSE 10? sky rulz Linux - Networking 1 08-30-2008 07:02 AM
DVD-Ram not mounting permissions issue. kernel-P4N1C Slackware 5 07-29-2008 11:52 PM
DVD RAM gone.. Can use DVD player???????? lin_myworld Linux - Hardware 3 12-21-2007 09:39 AM
LG DVD+-RW/RAM won't mount after writing DVD (growisofs/k3b) jaws_tas Linux - Hardware 1 03-25-2005 02:52 AM
How to play dvd s in regular user account? DVD-RAM How-To? Outabux Debian 1 07-08-2004 08:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration