LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-05-2011, 12:04 AM   #1
Yurlungur
LQ Newbie
 
Registered: Jul 2011
Location: Boulder, CO
Distribution: Fedora
Posts: 3

Rep: Reputation: Disabled
Post Permissions locked to read only on NTFS partition


Hi there. I'm pretty new to Linux. Though I've used it for a little bit, I barely know any shell commands. I recently migrated from Mint to Fedora. Installation went fine and I thought I was doing great until I tried to copy something onto one of my ntfs partitions (I got them automounted through changing fstab). Now I can't change the permissions with sudo chmod... it says I can, but nothing changes. And, while the folders are listed as allowing rw for the user group I set up, I can't actually change anything. I'm guessing I've done something wrong with my fstab file. Does anyone have any ideas?

My fstab file is:
Code:
UUID=3ba9753f-07b2-43e5-b5cc-571c19ad4620 /                       ext4    defaults,user_xattr        1 1
/dev/mapper/nvidia_fcficeibp6 swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/mapper/nvidia_fcficeibp3 /windows          ntfs-3g rw,user,dev,auto,suid,exec,async,gid=users,umask=002 0 0
/dev/mapper/nvidia_fcficeibp5 /storage          ntfs-3g rw,user,dev,auto,suid,exec,async,gid=users,umask=002 0 0
I should probably note that I'm using NVIDIA fake RAID 0, which is why my device locations are all /dev/mapper/nvidia_fcficeibp#


The command I have tried to change permissions is:
Code:
sudo chmod a+rw -R /storage
Thanks in advance for your help!

Last edited by Yurlungur; 07-05-2011 at 12:08 AM.
 
Old 07-05-2011, 12:23 AM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,330

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
sudo isn't used by default in Fedora. Use "su -" (without quotes), enter your root password and then your command. If you want to use sudo, check this site. Haven't done this myself so I don't know if it will work:

http://www.liberiangeek.net/2011/01/...a-14-laughlin/
 
Old 07-05-2011, 12:29 AM   #3
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,363

Rep: Reputation: 135Reputation: 135
Try to remount the partition with rw mode as root user:

Quote:
mount -o remount,rw /storage
 
Old 07-05-2011, 01:16 AM   #4
Yurlungur
LQ Newbie
 
Registered: Jul 2011
Location: Boulder, CO
Distribution: Fedora
Posts: 3

Original Poster
Rep: Reputation: Disabled
Wow, that was fast!


@yancek: Got it. Thanks for the tip. This doesn't seem to fix it... but its good to find out something else I was doing wrong.

@divyashree: the response I get is:
Code:
Remounting is not supported at present. You have to umount volume and then mount it once again.
so I tried
Code:
su
umount /storage
mount /dev
mount -o,rw /dev/mapper/nvidia_fcficeibp5 /storage
it works! Thanks both of you for your help! Will it work on reboot? Or do I need to setup a boot command or change the fstab file or something else?
 
Old 07-05-2011, 01:36 AM   #5
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
Depends what you mean exactly, but if you want the current mount mapping to 'stick', then yes, add a line to /etc/fstab (or amend the current one if it exists).
 
Old 07-05-2011, 02:18 AM   #6
Yurlungur
LQ Newbie
 
Registered: Jul 2011
Location: Boulder, CO
Distribution: Fedora
Posts: 3

Original Poster
Rep: Reputation: Disabled
@chrism0: but what line? I've already got the rw option in there for that mapping (see my first post). Why didn't that work before?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Folder permissions locked read-only odyssey84 Linux - Newbie 4 03-20-2010 12:21 AM
Read permissions for ntfs drive. Billy|B-A Linux - General 2 02-01-2005 11:20 PM
Can't change the read permissions on an NTFS partition as root? EOHooligan Linux - Newbie 4 01-09-2005 07:48 AM
Permissions for NTFS partition MikTheUser Slackware 5 07-08-2004 08:41 PM
Change permissions on NTFS partition to read for all users bax Linux - Newbie 6 05-13-2002 08:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration