-   Linux - Newbie (
-   -   Permissions Inherittance between nos Linux server and Mac osx client (

djlevi 11-19-2012 06:22 PM

Permissions Inherittance between nos Linux server and Mac osx client
I'm trying not to inherit permisions when copying files from Mac osx to nfs server on Linux.
I tried setgid, acl, etc without success. It works creating new files but It is not copying already made files. Ie: i copy a 700 file to nfsserver and stills The same permissions but i create new ones and get 777, what is like i want.
Is there any way to overriding source permissions? I could made with samba but not in nfs.
Thanks, i hope my explanation was clear.

tekhead2 11-20-2012 10:17 AM

How are you copying the files? Are you mounting the NFS share via finder in the desktop, or are you using a console command to mount it? OSX is based on BSD, but anything done in the finder will have different permissions than something you do in the console. It maybe best to mount it by hand via a command line and see if that will help.

djlevi 11-20-2012 12:25 PM

Hi, thanks for your answer.
Im mounting nfs shares with finder. In any case, its possible force writing permissions in server side overriding the old ones?

tekhead2 11-20-2012 03:56 PM

I think the issues your having maybe related to the umask on these files. I have read similar issues on Apples forums. What version of OSX are you running, apparently the umask is an issue with 10.6, I can't say for certain about 10.7 or 10.8 . Here is a KB article from Apple about umask settings You may want to run a test with a test machine and see if setting a custom umask fixes the issues.

djlevi 11-20-2012 06:29 PM

Hi, i already tried umask changing like article says. I made launched.conf with desired umask but only works with new files but not with copied ones, which maintains original owner and permissions.
I'll make some tests with acl and setgid again because I need to ensure all tests I made are correct. I thought setgid bit should work changing subfolders group ownership, but the problem is that permissions files with 700 came from somewhere, so I need they become 770 in order to access them trought group permissions. Maybe acl masks inheritance should work but it doesn't inherit.
Thanks again.

fakie_flip 11-21-2012 03:07 AM

tar the files first with

tar -cvpf myfiles.tar /backup

From tar's man page:


-p, --preserve-permissions
extract information about file permissions (default for supe-
The UID and GID of the files and directories must correspond with the same users between systems, but if not, it is easily fixed with the "chown -R directory" command.

djlevi 11-21-2012 05:51 PM

Thanks but it doesn't suit for this case. People copy files from finder, don't know command tools.

tekhead2 11-22-2012 12:29 PM

Heaven forbid that I suggest this, but have you tried running the file share server from OSX server, or maybe another protocol? Is there a specific reason for needing NFS ?

fakie_flip 11-26-2012 01:24 AM


Originally Posted by djlevi (Post 4834391)
Thanks but it doesn't suit for this case. People copy files from finder, don't know command tools.

Are they the ones needing to copy files? Or is it you? Then if it's you, why would it matter if those people used finder and don't know commands?

What you're asking for is not something uncommon, and there's several search results on Google providing answers.

djlevi 11-26-2012 06:57 AM

I have not problem managing files. If is there any problem i can fix permissions or whatever must be done. The users have this problem, and its hard to find any solution. Ive been googling a lot before this post.
The thing about command issue is about tar recomendation. I could not ask anybody to tar files and untar again to fix this. They are desktop users.
Ive already solve this with the solution a didnt want. I change UID for linux machine that has problem reading mac wrotten files. Now all its ok, but id liked to find any like samba solutions. In samba you can set permissions overriding original ones.
Thanks in any case for your help.

All times are GMT -5. The time now is 07:27 PM.