LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2017, 12:50 PM   #1
ezthurlow
LQ Newbie
 
Registered: Dec 2017
Posts: 3

Rep: Reputation: Disabled
Permissions Denied Although Owner


I am new to linux so there is probably something very obvious I am missing. I have created a folder called "Study203_Interim" and given the permissions "770" to it. I have made the user: xiaoxing.wang the owner of the folder and given "Interim" group permissions of the folder. Xiaxing is also in the Interim group. However, she is getting access denied when attempting to access it from a samba share on her Windows 7 PC. On her Windows PC, she logs into an active directory domain and her Windows username is identical to her linux username. Last week this user had access to this folder hosted on the linux share, now something has changed and she doesn't have access, although the permissions are exactly the same as last week...so it appears to me. I am not sure how to fix this one. Thanks in advance for any help you can offer!

Last edited by ezthurlow; 12-26-2017 at 12:52 PM. Reason: Trying to upload picture
 
Old 12-26-2017, 01:42 PM   #2
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,479

Rep: Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994
Try changing the permissions to 777 and see if that works. If it does, check the user's group membership again. If it doesn't, it's something with Samba.
 
Old 12-27-2017, 02:52 PM   #3
ezthurlow
LQ Newbie
 
Registered: Dec 2017
Posts: 3

Original Poster
Rep: Reputation: Disabled
update

I adjusted permissions to 777 and the user can now access the Study203_Interim folder, but nothing underneath that...because I did not apply 777 recursively. I also confirmed that the user is in the correct Interim group that has access to this folder. Any other ideas?
Attached Thumbnails
Click image for larger version

Name:	Interim.JPG
Views:	17
Size:	88.8 KB
ID:	26616  
 
Old 12-27-2017, 03:59 PM   #4
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,633

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
What's with the acl on that folder?
 
Old 12-28-2017, 01:41 PM   #5
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.5
Posts: 1,775

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Just a couple of troubleshooting questions for which I know not the answers:
I note a difference in the spelling of your user's name in the username and in the body of the post. Could just be a typo here, of course, but are you sure the user ids are the same?
Been awhile since I played with Samba, but doesn't the user need to be setup in samba as well as in linux and windows/AD?
 
Old 12-28-2017, 09:55 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,389

Rep: Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573
using "777" is almost always a BAD IDEA . "755" and "644" are the normal defaults

but why are you using the odd "770" ???
that is a bit odd
 
Old 12-29-2017, 04:49 AM   #7
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,704
Blog Entries: 7

Rep: Reputation: 2399Reputation: 2399Reputation: 2399Reputation: 2399Reputation: 2399Reputation: 2399Reputation: 2399Reputation: 2399Reputation: 2399Reputation: 2399Reputation: 2399
please enter
Code:
whoami
and post output here.
 
Old 12-29-2017, 10:37 AM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,389

Rep: Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573Reputation: 2573
have you used "chown" ?

Code:
su -

cd /home/samba/public/projects
chown -r YourUserName:users Biogen
and replace "YourUserName" with well your user name
 
Old 01-03-2018, 07:30 AM   #9
ezthurlow
LQ Newbie
 
Registered: Dec 2017
Posts: 3

Original Poster
Rep: Reputation: Disabled
Update 2

Sorry about slow response. In answer to all your questions, my knowledge of linux folder permissions is very limited so I am not sure how acl's got set on this folder or how it might affect the user accessing it. How do I tell what is set and whether that would affect it?

I was using "770" based on a recommendation of another friend. I wanted "Xiaoxing.Wang" and the "Interim" group to have full access to this folder and no one else. Would 755 be the best for this?

When I enter "whoami" the output is "root".

What will this command: "chown -r YourUserName:users Biogen" do?

So far, the only way I have been able to get Xiaoxing access to Study203_Interim and all the folders below is to give her the permissions you see in the screen shot.
Attached Thumbnails
Click image for larger version

Name:	Interim2.JPG
Views:	10
Size:	49.8 KB
ID:	26663  
 
Old 01-03-2018, 04:03 PM   #10
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,633

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Quote:
Originally Posted by ezthurlow View Post
How do I tell what is set and whether that would affect it?
Use 'getfacl'
See https://wiki.archlinux.org/index.php..._Control_Lists
Quote:

I was using "770" based on a recommendation of another friend. I wanted "Xiaoxing.Wang" and the "Interim" group to have full access to this folder and no one else. Would 755 be the best for this?
The 770 should be correct for what you want.
Quote:
When I enter "whoami" the output is "root".

What will this command: "chown -r YourUserName:users Biogen" do?
Recursively change ownership of Biogen (so all it's contents as well) to root:users
 
Old 01-09-2018, 08:19 AM   #11
tocii.
LQ Newbie
 
Registered: Jan 2018
Distribution: Ubuntu, Mint
Posts: 27

Rep: Reputation: Disabled
Is it good now?

give folder owner permission to your user with 'chown -r' command. Then will be good

Last edited by tocii.; 01-09-2018 at 08:20 AM.
 
Old 01-09-2018, 09:57 AM   #12
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,011

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Hi ezthurlow,

Your statement in your original post to the effect that access for the user you mentioned functioned properly up until a week ago and then it just stopped working, leads me to wonder whether this is not simply a question of mismatched versions of the smb protocol.

In the course of regular updates, both Windows and linux may update their respective versions of the smb protocol, changing the default. Windows 7 clients may try to connect using version 1 of the protocol. You may want to experiment with adding the following line to your server's smb.conf file (in the [global] section :

Code:
protocol=SMB1
... or ...

Code:
min protocol=SMB1
Cheers,

Last edited by Rickkkk; 01-09-2018 at 09:59 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Permission denied while uploading files in htdocs because owner and group is apache unclesamcrazy Linux - Newbie 7 09-17-2014 08:42 AM
Force owner, owner group, permissions... leamassiot Linux - General 8 03-13-2014 04:40 AM
[SOLVED] Permission denied when extracting gcc even if the user 'lfs' is the owner jddantes Linux From Scratch 2 09-23-2013 01:25 AM
permissions to the non-owner admins geekG Linux - Security 1 05-04-2013 06:43 PM
Why is access denied to files I haven't made but I'm the owner, I'm the root. Sonhi Fedora 8 08-12-2008 07:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration