Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 04-27-2009, 10:23 PM   #1
LQ Newbie
Registered: Apr 2009
Posts: 20

Rep: Reputation: 0

Ok ive seen several questions regarding this problem and have found a solution. (its worked for me anyways lol)
Open the terminal and login as root:

Change the directory to where the files/folders are located:
cd /dir/dir/dir

Then change the ownership of the file/folder:
This is using my login name (replace with your own)
chown -r leighroy *
if the above doesnt work then use:
chown leighroy *

Keep the terminal open while you do what you have to do with the file/folders.

Also i change the ownership back to root after i am done with that particular file/folder.

Hope this helps some people that have had problems with this.
Old 04-28-2009, 02:27 AM   #2
Senior Member
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,064

Rep: Reputation: Disabled
That is a little bit brutal / global (maybe except for when you are in your /home/leighroy directory). I'd suggest you chown only the file(s) which are giving you truoble...
Old 04-28-2009, 02:33 AM   #3
David the H.
Bash Guru
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,837

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
Uhm, just what problem is this supposed to solve, anyway? If you need to manipulate root files there are certainly much better ways to do it than to chown them. Sudo, for example. For that matter, if you already have root access, why do you need to change anything?
Old 04-28-2009, 02:51 AM   #4
LQ Newbie
Registered: Apr 2009
Posts: 20

Original Poster
Rep: Reputation: 0
well my browser was slow so i needed to disable the ipv6 and i kept getting the permissions bullshit.
couldnt use my dvd or cd drive.
so it solved some major problems for me and for some reason i couldnt do in the terminal.
and no i dont have root access

Last edited by leighroy; 04-28-2009 at 02:54 AM.
Old 04-28-2009, 03:51 AM   #5
LQ Guru
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,417

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
In your 1st post you said you logged in as root (su), so you DO have root...
In any case, you should really use 'su -', the '-' gives you roots env, otherwise you become root but with your orig user's env.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Permissions Denied kapilbajpai88 Linux - Newbie 4 11-24-2008 06:06 PM
Permissions denied dms05 Linux - Newbie 7 11-03-2007 04:31 PM
permissions denied mrbrucelee Linux - General 8 06-29-2006 03:29 PM
Denied Permissions Jeebizz Slackware 4 09-05-2004 04:08 PM
Unable to run /usr/sbin/pppd. --> Check permissions [solved] flosch Linux - Networking 0 05-05-2004 10:08 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:56 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration