LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-31-2004, 09:43 AM   #1
Commando464
Member
 
Registered: Jul 2004
Location: Edmonton, Canada
Distribution: Fedora Core 4
Posts: 82

Rep: Reputation: 15
Permission problem


Have a problem with permissions on some folders.

I am trying to change permissions on files and folders in my Windoze partition. Everytime i try to change permissions on files or folders, an error message says that i dont have enough authorization to make the changes.

I have checked all the files and they are all owned by root.

I am doing this through Konqueror. I have tried in the Super user mode and have also tried to make the changes by logging on as root.

Has someone else come across this and whats the best way to fix it.

Thanks

 
Old 07-31-2004, 09:51 AM   #2
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 38
Check how your windows partition is mounted in fstab. If it's mounted read-only, you might not be able to give write/execute permissions
 
Old 07-31-2004, 10:24 AM   #3
Commando464
Member
 
Registered: Jul 2004
Location: Edmonton, Canada
Distribution: Fedora Core 4
Posts: 82

Original Poster
Rep: Reputation: 15
This is what my fstab looks like

/dev/hdb2 / ext3 acl,user_xattr 1 1
/dev/hda3 /data1 ext3 acl,user_xattr 0 0
/dev/hda5 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvd /media/dvd subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/hda2 /Data ext3 user,acl,user_xattr 1 2
/dev/hda1 /home/rsagoo/Windows vfat user 0 0


Most of the settings were done by installation process in SuSE. I am still learning what it all means.

Thanks
 
Old 07-31-2004, 03:53 PM   #4
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Try changing this:
/dev/hda1 /home/rsagoo/Windows vfat user 0 0
to this:
/dev/hda1 /home/rsagoo/Windows vfat auto,user,rw 0 0

That will mount it automatically for you (or use noauto if you don't like that) and it will mount it as read-write. Might help you...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Permission Problem Hero Doug Fedora 2 09-12-2005 02:41 AM
Permission problem comprookie2000 Linux - Hardware 3 11-02-2004 02:58 PM
permission problem.. bit7 Linux - Software 4 02-26-2003 06:08 AM
permission problem trusouthrnplaya Linux - General 2 04-16-2002 01:05 AM
Ftp permission problem 360 Linux - Networking 4 02-19-2002 11:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration