LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-23-2018, 03:13 PM   #1
rlcosta14
LQ Newbie
 
Registered: Aug 2018
Posts: 13

Rep: Reputation: Disabled
Permission denied with conf file


Hi, i've been trying to make Debian 9 allow tap-to-click on my laptop.

I've removed the xserver-xorg-input-synaptics package:

apt remove xserver-xorg-input-synaptics

Installed xserver-xorg-input-libinput:

apt install xserver-xorg-input-libinput


And when creating 40-libinput.conf file:

echo 'Section "InputClass"
Identifier "libinput touchpad catchall"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
Driver "libinput"
Option "Tapping" "on"
EndSection'
sudo > /etc/X11/xorg.conf.d/40-libinput.conf

It displays Permission denied...
Can anyone give me an advice on how to execute the file created?

Fixed!

Update:
Can't get in with the correct password after restarting DM:
systemctl restart gdm3

Last edited by rlcosta14; 08-24-2018 at 11:39 AM.
 
Old 08-23-2018, 04:06 PM   #2
MadeInGermany
Senior Member
 
Registered: Dec 2011
Location: Simplicity
Posts: 1,203

Rep: Reputation: 549Reputation: 549Reputation: 549Reputation: 549Reputation: 549Reputation: 549
You perhaps mean
Code:
sudo echo '
...
' > file
Your problem is: the shell opens the file for writing *before* it invokes sudo.
Quoting the > is no solution either (sudo does not invoke another shell that handles the > )
A solution:
sudo runs a program that writes the file. And the shell can feed the sudo with a pipe.
Code:
echo '
...
' | sudo dd of=file
The shell opens the pipe to sudo, this does not need privileges.

Last edited by MadeInGermany; 08-23-2018 at 04:08 PM.
 
1 members found this post helpful.
Old 08-23-2018, 04:16 PM   #3
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,113

Rep: Reputation: 421Reputation: 421Reputation: 421Reputation: 421Reputation: 421
First make sure the installation of libinput didn't already create the file by default in /usr/share/X11/xorg.conf.d ... (it does, for instance, in Arch Linux).

Then, just copy the file to the /etc/X11/xorg.conf.d/ directory and edit it to add the tapping option.

Cheers.
 
1 members found this post helpful.
Old 08-23-2018, 04:23 PM   #4
rlcosta14
LQ Newbie
 
Registered: Aug 2018
Posts: 13

Original Poster
Rep: Reputation: Disabled
It worked but another problem came up...
Once i restarted the DM:
systemctl restart gdm3

i can't seem to be able to enter, once i place my pw it does nothing... Did i screw up?

Last edited by rlcosta14; 08-23-2018 at 05:04 PM.
 
Old 08-24-2018, 09:02 AM   #5
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,113

Rep: Reputation: 421Reputation: 421Reputation: 421Reputation: 421Reputation: 421
Quote:
Originally Posted by rlcosta14 View Post
It worked but another problem came up...
Once i restarted the DM:
systemctl restart gdm3

i can't seem to be able to enter, once i place my pw it does nothing... Did i screw up?
Hi rlcosta,

This is odd.

When you copied and edited 40-libinput.conf, did you simply add the tapping option to the touchpad block or did you make any other changes (ex. remove anything, change something else ...) ? I am reaching here - I wouldn't expect this type of mistake to negatively impact the functionality of your DM.

Did you make any other changes at the same time ?

If the above doesn't help, what I would do is disable the systemd service for gdm, boot into the console, completely remove gdm, reboot, reinstall gdm and retry manually starting it. Then try to log in via the DM and if it works again, re-enable the gdm service.

If this doesn't work, time to examine the logs for anything unusual ... If it comes to that, and you need guidance, let us know and either I or some of the other members should be able to help.

Let us know how you make out.
 
1 members found this post helpful.
Old 08-24-2018, 11:36 AM   #6
rlcosta14
LQ Newbie
 
Registered: Aug 2018
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Rickkkk View Post
Hi rlcosta,

This is odd.

When you copied and edited 40-libinput.conf, did you simply add the tapping option to the touchpad block or did you make any other changes (ex. remove anything, change something else ...) ? I am reaching here - I wouldn't expect this type of mistake to negatively impact the functionality of your DM.

Did you make any other changes at the same time ?

If the above doesn't help, what I would do is disable the systemd service for gdm, boot into the console, completely remove gdm, reboot, reinstall gdm and retry manually starting it. Then try to log in via the DM and if it works again, re-enable the gdm service.

If this doesn't work, time to examine the logs for anything unusual ... If it comes to that, and you need guidance, let us know and either I or some of the other members should be able to help.

Let us know how you make out.
I really apreciate the help, what i've done is follow this tutorial:

https://unix.stackexchange.com/quest.../337218#337218

Starts on "Debian Stretch (updated)"

Everything worked until executing the systemctl restart gdm3
I'll try figure out how to do the steps above.

I've done Ctrl+Alt+F3, then placed login info and got in, i assume i'm in the console atm, how do i remove gdm?

Last edited by rlcosta14; 08-24-2018 at 11:45 AM.
 
Old 08-24-2018, 01:15 PM   #7
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 13,100

Rep: Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144
when you remove gdm you will have no graphical display any more (just that console). So probably it is not what you want.
you can try to remove the file created (/etc/X11/xorg.conf.d/40-libinput.conf), probably that helps to restore the original configuration. But if you have modified other things ....
 
1 members found this post helpful.
Old 08-24-2018, 02:01 PM   #8
rlcosta14
LQ Newbie
 
Registered: Aug 2018
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
when you remove gdm you will have no graphical display any more (just that console). So probably it is not what you want.
you can try to remove the file created (/etc/X11/xorg.conf.d/40-libinput.conf), probably that helps to restore the original configuration. But if you have modified other things ....
So the systemctl restart gdm3 isn't the reason for it not be working, could be the file that i created?
 
Old 08-24-2018, 02:02 PM   #9
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 13,100

Rep: Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144Reputation: 4144
yes, I think
 
1 members found this post helpful.
Old 08-24-2018, 02:43 PM   #10
rlcosta14
LQ Newbie
 
Registered: Aug 2018
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
yes, I think
rm /etc/X11/xorg.conf.d/40-libinput.conf

remove /etc/X11/xorg.conf.d/40-libinput.conf? y
cannot remove '/etc/X11/xorg.conf.d/40-libinput.conf' Permission denied.
 
Old 08-24-2018, 03:02 PM   #11
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,113

Rep: Reputation: 421Reputation: 421Reputation: 421Reputation: 421Reputation: 421
Hi again rlcosta14,

As mentioned in my above post, I would also suggest you begin by verifying that 40-libinput.conf file. What is important is that when you copied it into the /etc/X11/xorg.conf.d/ directory and edited it, you *added* the tapping option line but *did not change anything else*.

So first, compare the 2 files: /etc/X11/xorg.conf.d/40-libinput.conf and /usr/share/X11/xorg.conf.d/40-libinput.conf .... They should be identical except for that line you added. If not, as suggested above, delete the file you edited and start over.

You will only be able to create, edit or delete a file in the /etc directory tree with elevated privileges (it being a system directory). So use sudo. For example :

Code:
sudo rm /etc/X11/xorg.conf.d/40-libinput.conf
... See how your system behaves after rebooting. If you are still unable to login again with gdm, you can try the next level of troubleshooting (removing and reinstalling gdm).

Let us know how things go !
 
1 members found this post helpful.
Old 08-24-2018, 03:06 PM   #12
rlcosta14
LQ Newbie
 
Registered: Aug 2018
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Rickkkk View Post
Hi again rlcosta14,

As mentioned in my above post, I would also suggest you begin by verifying that 40-libinput.conf file. What is important is that when you copied it into the /etc/X11/xorg.conf.d/ directory and edited it, you *added* the tapping option line but *did not change anything else*.

So first, compare the 2 files: /etc/X11/xorg.conf.d/40-libinput.conf and /usr/share/X11/xorg.conf.d/40-libinput.conf .... They should be identical except for that line you added. If not, as suggested above, delete the file you edited and start over.

You will only be able to create, edit or delete a file in the /etc directory tree with elevated privileges (it being a system directory). So use sudo. For example :

Code:
sudo rm /etc/X11/xorg.conf.d/40-libinput.conf
... See how your system behaves after rebooting. If you are still unable to login again with gdm, you can try the next level of troubleshooting (removing and reinstalling gdm).

Let us know how things go !
Literally figured how what i was doing wrong...
Once i tried rm /etc/X11/xorg.conf.d/40-libinput.conf
and it didnt work i tried:
sudo rm/etc/X11/xorg.conf.d/40-libinput.conf
without the space between the rm and the file name -.-"
I'm now able to boot, its all good.

Still need to figure out how to enable tap-to-click though...
 
Old 08-24-2018, 03:08 PM   #13
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,113

Rep: Reputation: 421Reputation: 421Reputation: 421Reputation: 421Reputation: 421
Excellent news - is your tapping option wirking as well ?
 
1 members found this post helpful.
Old 08-24-2018, 03:12 PM   #14
rlcosta14
LQ Newbie
 
Registered: Aug 2018
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Rickkkk View Post
Excellent news - is your tapping option wirking as well ?
Just ran egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices

found out i have a synaptics touchpad.
I'm using Gnome and was able to enable it.
It's all solved, i'll close the thread.
Thanks for all the help, from everyone.
 
Old 08-24-2018, 04:05 PM   #15
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,113

Rep: Reputation: 421Reputation: 421Reputation: 421Reputation: 421Reputation: 421
Fantastic - cheers !
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] # /etc/sysctl.conf -p : permission denied mridul chandhok Linux - Newbie 9 03-11-2011 08:38 AM
bash: /etc/ld.so.conf: Permission denied theKbStockpiler Linux - General 5 09-11-2010 05:01 PM
Unable to open configuration file "/etc/samba/smb.conf" Permission denied jijawm Linux - Enterprise 8 08-18-2010 11:47 AM
/etc/make.conf >permission denied eytan *BSD 5 03-06-2005 09:48 PM
/etc/lilo.conf permission denied ginge12 Linux - Newbie 14 09-18-2003 08:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration