-   Linux - Newbie (
-   -   permission denied when running program (

nadia_kh 07-16-2012 10:21 AM

permission denied when running program
i use the TraNSv1.2. The installation is correct. when i run the program the permission denied message is appeared!!!!!

i log in as root but the problem is not solved

Do you help me please?


the error is
Quote: Cannot run program "/home/nadia/work/ns-allinone-2.35/ns-2.35": error=13, Permission denied

richardg1952 07-16-2012 12:22 PM

if root doesn't have permission then it's likely the execute bit(s) are not set.
ls -l /home/nadia/work/ns-allinone-2.35/ns-2.35
and post the results.
What is TraNS?

LceeL 07-16-2012 01:48 PM

set permissions
Try setting the permissions on that program to 777 - as root, chmod 777 </PATH/program name>. If that works you can then change permissions, later, to suit your environment better.


lleb 07-16-2012 03:30 PM

no need to go so crazy loose with permissions. a simple chmod +x /path/to/foo will do.

Tinkster 07-16-2012 05:08 PM

Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.

All times are GMT -5. The time now is 07:55 PM.