LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-21-2009, 04:29 PM   #1
MilanK
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Rep: Reputation: 0
Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password,keyboard-inte ract


I'm trying to scp a couple of files from a RedHat Linux Enterprise 4 machine to a couple of other machines (one a Mac OSX and the other a Solaris). I see the same behavior with either remote machine. I'm able to manually scp files from my Linux machine to either remote machine without using a passphrase because I set up the appropriate public and private keys on all the machines. However, when I try to scp the same files as part of a cron script I get "Permission denied". Here are the relevant lines from my Cron Log attempting to scp to a remote machine called rem. Thanks very much.

+ /usr/bin/scp -p /home/Milan/file1 /home/Milan/file2 Milan@rem:/Users/Milan/Documents
Permission denied, please try again.
Permission denied, please try again.
Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password,keyboard-inte ractive).
lost connection

Here are the relevant portions from verbose logs of the successful command-line scp (1) and the unsuccessful cron scp (2). I'd appreciate any insight anyone might be able to lend.

1.
debug1: Next authentication method: gssapi-with-mic
debug1: Miscellaneous failure
Unknown code krb5 195

debug1: Trying to start again
debug1: Authentications that can continue: publickey,gssapi-
keyex,gssapi-with-mic,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering public key: /home/Milan/.ssh/id_dsa
debug1: Server accepts key: pkalg ssh-dss blen 433
debug1: Authentication succeeded (publickey).

2.
debug1: Next authentication method: gssapi-with-mic
debug1: Miscellaneous failure
Unknown code krb5 195

debug1: Trying to start again
debug1: Authentications that can continue: publickey,gssapi-
keyex,gssapi-with-mic,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /home/Milan/.ssh/identity
debug1: Trying private key: /home/Milan/.ssh/id_rsa
debug1: Offering public key: /home/Milan/.ssh/id_dsa
debug1: Server accepts key: pkalg ssh-dss blen 433
debug1: PEM_read_PrivateKey failed

Last edited by MilanK; 05-22-2009 at 11:37 AM. Reason: Greater detail
 
Old 03-20-2012, 03:44 AM   #2
tandn
LQ Newbie
 
Registered: Mar 2012
Posts: 1

Rep: Reputation: Disabled
Hi friend,
May be your .ssh directory is too open, change this into 755
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh -- Permission denied (publickey,password,keyboard-interactive). davidkline Linux - Networking 10 05-07-2012 12:16 AM
ssh client say me Permission denied.(publickey). linderox Linux - Networking 2 02-27-2008 09:36 AM
Permission denied (publickey,password,keyboard-interactive) cccc Linux - General 3 05-31-2007 05:32 PM
Permission denied (publickey,password,keyboard-interactive). rockymaxsource Linux - Networking 3 04-27-2007 08:32 PM
Gssapi Kenji Miyamoto Linux - Software 1 05-25-2005 12:00 AM


All times are GMT -5. The time now is 04:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration