-   Linux - Newbie (
-   -   permission denied after loading files to server (

heyme 11-17-2007 10:27 AM

permission denied after loading files to server
Yep, newbie, that's me:-)
Recently started using Ubuntu 7.10, and am trying out Bluefish editor for making PHP pages, and gFTP for loading to my webserver.
Now when I want to view them I get the '403 page forbidden'.
I checked, and saw that the files belong to 'root'. I know how to change my user to root, but not sure what the permissions are to set or exactly how to set them (and preferably in such a way that all files saved in a folder and below get the same permissions).
Neither do I know if there is a setting in bluefish or gFTP which are responsible for the permissions on the files, I never had this problem before really..
If there is a setting I can set so that all files and folders within a folder will get the correct permissions I'd be very happy to know.

Already many thanks,

MasterC 11-17-2007 10:33 AM

I don't have gFTP at my fingertips right now, but I believe it's in the lower right portion of the application. There is a means to change permissions, look for something that says chmod.

Also, your permission issue:

You may want to look at the server logs to see what they say about the error. It may just be a directory permissions thing (directories need execute permissions to allow access to them). The PHP files themselves are ok to be owned by root; it's probably that there aren't any read permissions for world:
chmod a+r
chmod 764

Might be sufficient.

Good luck!


All times are GMT -5. The time now is 04:35 PM.