LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Permission Denied (https://www.linuxquestions.org/questions/linux-newbie-8/permission-denied-266387/)

ptreves 12-14-2004 03:37 PM

Permission Denied
 
Hello,


I tried to apply a Oracle Patch.
When I ran the patch, I got the following message:

bash: -- ............: permission denied

1) What exactly does the permission denied mean ?
2) Has the patch been applied or not ?

The patch is suppose to modify the ld.so file.
There are 3 files: (ld.so.conf, ld.so.cache, ld.so.preload). I am not sure which file should be modified ??
I get the impression that the patch was not applied. From the root user, I switched to the oracle user.

PT

ddu_ 12-14-2004 03:45 PM

Permissions problem maybe? Did you give +x permissions to that file?

reddazz 12-14-2004 03:48 PM

It means exactly what it says, you don't have enough rights to install that patch. You may need to do it as root or give execution permissions as mentioned above.

ptreves 12-14-2004 03:53 PM

Changing File Permissions
 
Hello,

The patch says that it modifies the ld.so file.
Looking through the /etc folder, I have 3 variations of that file.

1) Will running: chmod +x ld.so... on all 3 files do the job ?

PT

ddu_ 12-14-2004 03:55 PM

You should only have to give the execute permission to what you're trying to install, and have rights to modify the files it effects.

sudo, or do it as root, and give +x to the file.

ptreves 12-14-2004 03:56 PM

libcwait + ld File Roles
 
Hello,

The patch is suppose to append/modify the following files:

/etc/libcwait.so
/etc/ld.so

As I have said, I have 3 variations of the file:

ld.so.cache
ld.so.conf
ld.so.preload

1) What is the role of these files ?

PT

ddu_ 12-14-2004 04:00 PM

man ld.so :D

It gives you a pretty good list of what each does under "Files"

ptreves 12-16-2004 03:14 PM

Command not found ??
 
Hello,

When typing: su - oracle

I get the message: -bash: -a: command not found

PT


All times are GMT -5. The time now is 12:44 PM.