-   Linux - Newbie (
-   -   Pen drive not mounted ...."Unable to mount, No media in drive" (

subashk80 08-10-2009 07:46 AM

Pen drive not mounted ...."Unable to mount, No media in drive"
hello, I am new to linux. My recently purchased pen drive is not detected in Windows, When i tried it in my Ubuntu 8.04 it say "Unable to Mount location, No media in drive". How could i format my drive, so that it could be detected. Actually i think it was all due to some stupid virus in windows...Thanks!!

FireRaven 08-10-2009 07:52 AM

First thing you want to do is check if your drive has any readable partitions.
To do this type "#dmesg | tail" after plugging in your drive and see if it shows where your drive is mounted. It will be something like /dev/sda or /dev/sdb.

After that look for the partition by typing #ls /dev/sd*

If your drive was sdb, then the partition will show as /dev/sdb1
If you can see /dev/sdb and no /dev/sdb1 and you are sure sdb was your USB drive, then I'm pretty sure that's a guarantee you have lost your partiton.

subashk80 08-11-2009 06:39 AM

Thz....Wat do i do if i had lost my partition in the disk!! How do i create it again??

FireRaven 08-11-2009 06:51 AM

You can run fdisk or parted to create new partitions.
Just run

#fdisk /dev/sdb
where sdb is your USB drive.

Once in fdisk, hit 'p' then Enter to view your current partitions (just to verify there defiantly are none and you are on the correct drive).

Then type 'n' Enter to create a new primary partition.
When you are done type 'w' Enter to save and close fdisk.

Then run:
#mkfs.ext3 /dev/sdb1
on your new partition to format it.

repo 08-11-2009 06:51 AM

Try gparted to partition and format the drive.

apt-get install gparted

subashk80 08-17-2009 01:23 AM

hi i ran the "#dmesg | tail" command it shows that there is a USB removable storage disk, but shows a error

"segfault at 00000019 eip b6d80f44 esp bfe55e60 error 4".
The fdisk command says there is no media, and gpart too does not show it??

what do i do!!

FireRaven 08-17-2009 01:38 AM

I'm not too sure what this error means.
Do you have the last few lines of the dmesg handy - someone is bound to know what it is...

All times are GMT -5. The time now is 06:39 PM.