LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   pcmcia cisco aironet 350 (https://www.linuxquestions.org/questions/linux-newbie-8/pcmcia-cisco-aironet-350-a-25570/)

net travels 07-11-2002 03:57 PM

pcmcia cisco aironet 350
 
I'm trying to install an aironet 350 card. I'm using RH 7.3. I've installed the drivers provided by Cisco. My access point authenticates the card, but no IP gets assigned. The network configuration applet does not list the card. Any help/comments as to what I need to do welcomed.

Thanks.

finegan 07-11-2002 09:31 PM

Have you tried to invoke the dhcp client manually, with:

dhcpcd ethX

Whatever ethernet device the card is will be the X, if you have onboard ethernet and its configured, that probably means the cisco is eth1.

Cheers,

Finegan

net travels 07-12-2002 09:32 AM

Thanks for replying.


Thats just it, I Have no ethx. I've been reading about installing NICs, but never have figured out how to tell exactly what driver is binded to the card or how to change it.

I ran Cisco's installer "sh ./cwqinstall" the folder created and I was able to run the ACU utility and put my SSID. Once I put my SSID in my radio authenticated me. But ifconfig shows only lo.
Any other suggestions.

Thanks.

:Pengy:

finegan 07-12-2002 06:20 PM

ifconfig -a

ifconfig only lists the devices currently up. Ifconfig -a will list all available.

Cheers,

Finegan

net travels 07-15-2002 09:15 AM

ifconfig -a did show a eth0 and dhcpcd eth0 brought the card up. Thanks to you both.

One more question though. How do stop from having to type dhcpcd eth0 after every reboot. I've seen doc on how to edit liloconf, but I chose grub as my boot.

finegan 07-15-2002 02:28 PM

Nah, this doesn't have to do with a bootloader. In /etc/sysconfig/networking-scripts there is a file called ifcfg-eth0 or somesuch... you can hand edit that to suit, or...

netconfig

I forgot about netconfig for a minute that's why the long is before the short. This is going to make it so that the machine will try for a dhcp lease from the router for 1 minute on boot. If you're out of range, or the router is off, its still going to sit there like a dink for a full minute (its not hung, that tricks a lot of people). If the card is external, you can just yank the card before booting. Or...

You can edit the file /etc/pcmcia/network.opts and hopefully that will work. The distros haven't been keeping up with the advancements in pcmcia lately and its a little bit of a juggle to get things tweaked for ease nowadays.

3-4 ways to do anything, fun eh?

Cheers,

Finegan


All times are GMT -5. The time now is 08:22 AM.