LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Password Authentication does not seem to work well in Tinycore linux (https://www.linuxquestions.org/questions/linux-newbie-8/password-authentication-does-not-seem-to-work-well-in-tinycore-linux-4175510610/)

${i} 07-09-2014 03:26 PM

Password Authentication does not seem to work well in Tinycore linux
 
Hello LQ members

I went and tried a distro called tinycore linux in a virtualbox.

During the installation i was leery as to why it didn't ask to setup a password for root and/or the default tc user account.

I read the tinycore pdf book they have online. According to the book, I used the boot codes secure ( this setups the passwords ) and noautologin.

When I rebooted, it prompted me to create a password for root and tc. After creating the passwords, the login prompt appeared.

Long story short, it didn't work. I enter root for the login and then I enter my password. What I get is the login prompt again and again. After 3 failures to login as root. I then tried the user account tc.

When I enter tc as the login, it logged me right in the system without prompting me for a password.

I'm not sure of what to make of this. I created passwords for root and the tc user. Root doesn't want to log in even though I enter the correct password and tc logs in with just the username and doesn't prompt for a password.

Am I missing a step or is tinycore design not to use password authentication? Thanks

${i} 07-09-2014 07:26 PM

I've did a google search on this tinycore password authentication thing and I am not alone. It turns out the developers designed tinycore that way. They rely on the sudoers file for root privileges for tc. Even still. when you invoke sudo su or sudo command it still doesn't prompt for a password.

I'm not going to use a distro with no password authentication feature, so I will search for a another minimalistic distro for the VM like salix, slitaz or other.


All times are GMT -5. The time now is 02:13 AM.