LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   PartitionMagic 7.0 and DOS fdisk don't work anymore (https://www.linuxquestions.org/questions/linux-newbie-8/partitionmagic-7-0-and-dos-fdisk-dont-work-anymore-82518/)

gfischer 08-16-2003 08:21 AM

PartitionMagic 7.0 and DOS fdisk don't work anymore
 
I put up the following post at the Software Forum a week ago but did not get any useful replies, maybe it was the wrong forum for a Newbie, that's why I'll try it again here.

"I installed RedHat Linux 9.0 on a system running Win98SE. I have a hard drive with partitions c:\ to f:\ and used PartitionMagic 7.0 to create additional space for Linux. I made a stupid mistake with the bootloader during the Linux setup and could not get into Windows anymore. Eventually I managed to restore Windows but I ended up with a 4 MB d:\ drive with nothing on it that screwed up the starting of nearly all my programs because the drive letters all moved down by one. The space allocated for Linux is no longer available under Windows and PartitionMagic shows the whole extended partition (c:\ to f:\) as "BAD", therefore I cannot make changes to the partitions anymore. Even fdisk under DOS freezes when I try to use it and that has never happened to me before. I noticed that the empty d:\ drive is FAT whereas all other logical drives are FAT32 and I tried to use the Windows FAT Converter but it reported that the drive is too small for conversion.
The funny thing is that Windows still works fine except for the changed drive letters. Any ideas?"

I have meanwhile been able to eliminate the empty d:\drive, my drive letters are back to normal and Windows works fine. I have also found out (on my own I might say, nobody came up with that information) that PM 7.0 does not support ext3 partitions. However, reinstalling RH 9.0 several times using the ext2 format did not solve the problem, PM still reports the whole drive as "BAD" and DOS fdisk still hangs. I have even tried to install an earlier Linux version (RH 7.2) which previously did not give me such problems but it also aborted.

Just to make some things clear and to avoid silly answers like "You cannot access a Linux partition from Windows because you partitioned it for Linux": I want to start using Linux seriously but I also want to continue using Windows, at least for a while. I also want to be able to resize partitions from within Windows with PM (both Win & Linux) because I've used it for years and because I think it's fantastic.

Right now I cannot even re-partition or re-format my hard drive because nothing works and I'm short of 5 GB disk space that I would like to recover.

a_pluss 08-17-2003 02:09 PM

I had the same problem yesterday with rh9 and this is the way I fix it. I run the installation software again and I choose to do the partition manually. when I got to the hard drives, I select the partition where rh9 was installed and I click on "delete" it deleted that partition and I got the whole hd again. I choose new partition and select the proper settings for it and it installed fine. When I boot up on WinXP and run partition magic, I was able to see both partitions, the one for linux and the nt.


All times are GMT -5. The time now is 06:17 AM.