Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 08-05-2004, 10:16 PM   #1
LQ Newbie
Registered: Aug 2004
Posts: 6

Rep: Reputation: 0
Partition Question (Slackware 10)

Well I've got another stupid question.

I've got my partions (hda1, hda2 (swap), hda3) set up, but when I try to mount them I get "FS Linux is not supported by kernel.

What type should I be using for these partitions in fdisk?

Also, what should my fstab look like, as I'm a bit confused about that as well.

Old 08-05-2004, 10:21 PM   #2
bruno buys
Senior Member
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
What mount command are you using? Post here the output of
cat /etc/fstab
So we can help you.
Old 08-06-2004, 09:20 AM   #3
LQ Newbie
Registered: Aug 2004
Posts: 6

Original Poster
Rep: Reputation: 0
here's the output:

/dev/hda1 / reiserfs defaul ts 1 1
/dev/hda2 / linux defaul ts 0 0
/dev/hda3 / linux defual ts 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto ,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto ,owner 0 0
devpts /dev/pts devpts gid=5, mode=620 0 0
proc /proc proc defaul ts 0 0

Old 08-06-2004, 11:14 AM   #4
LQ Newbie
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware 12.1
Posts: 25

Rep: Reputation: 15
The partitions /dev/hda2 and /dev/hda3 need to be formatted.

Back up any important personal files then:

su root


-select hda2 (down arrow key)
-select Type (right arrow key), then hit any key, then type 82 (for Linux swap)
-select write (right arrow key), then type yes.
-select quit

to format the swap partition with block checking type
mkswap -c /dev/hda2

swapon /dev/hda2

now to format /dev/hda3 with the reiser file system type
mkfs -t reiserfs /dev/hda3

Now you need to edit the /etc/fstab file so type
vi /etc/fstab

(you may already know this part!)
to enter text input mode press i
to delete you must press the escape key followed by x
to re-enter text press i key again and so on....

to save and quit the vi editor press the escape key then :wq enter/return
to quit vi without saving press escape :q! enter/return

Edit you fstab file to look like this:

/dev/hda2 swap swap defaults 0 0
/dev/hda1 / reiserfs defaults 1 1
/dev/hda3 /home reiserfs defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,user 0 0
devpts /dev/pts devpts gid=5, mode=620 0 0
proc /proc proc defaults 0 0
Old 08-06-2004, 06:57 PM   #5
bruno buys
Senior Member
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
Gescom is right, "linux" is no filesystem name. This is why mount gives you the error msg. Follow what he says.
Pay attention to the "defaults" parameter, on your fstab. Yours is mistyped, now.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware 10.1 can't see partition table ramke Slackware - Installation 2 04-26-2005 03:38 AM
slackware partition salahuddin_66 Slackware 7 08-07-2004 09:09 AM
How should I partition my 4gb for slackware neroagent Slackware 3 04-10-2004 01:58 AM
Storage Partition Filesystem question for Dual boot Slackware and Windows XP Razza2004 Linux - General 4 03-31-2004 08:14 PM
How do I install slackware on a partition made by partition magic in windows bling bling Slackware 4 06-29-2003 12:16 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:52 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration