LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Partition Question (Slackware 10) (https://www.linuxquestions.org/questions/linux-newbie-8/partition-question-slackware-10-a-214050/)

abrahamfroman 08-05-2004 09:16 PM

Partition Question (Slackware 10)
 
Well I've got another stupid question.

I've got my partions (hda1, hda2 (swap), hda3) set up, but when I try to mount them I get "FS Linux is not supported by kernel.

What type should I be using for these partitions in fdisk?

Also, what should my fstab look like, as I'm a bit confused about that as well.

Thanks!

bruno buys 08-05-2004 09:21 PM

What mount command are you using? Post here the output of
cat /etc/fstab
So we can help you.

abrahamfroman 08-06-2004 08:20 AM

here's the output:

/dev/hda1 / reiserfs defaul ts 1 1
/dev/hda2 / linux defaul ts 0 0
/dev/hda3 / linux defual ts 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto ,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto ,owner 0 0
devpts /dev/pts devpts gid=5, mode=620 0 0
proc /proc proc defaul ts 0 0


thanks.

gescom 08-06-2004 10:14 AM

The partitions /dev/hda2 and /dev/hda3 need to be formatted.

Back up any important personal files then:

type
su root

type
cfdisk

-select hda2 (down arrow key)
-select Type (right arrow key), then hit any key, then type 82 (for Linux swap)
-select write (right arrow key), then type yes.
-select quit

to format the swap partition with block checking type
mkswap -c /dev/hda2

type
swapon /dev/hda2


now to format /dev/hda3 with the reiser file system type
mkfs -t reiserfs /dev/hda3


Now you need to edit the /etc/fstab file so type
vi /etc/fstab

(you may already know this part!)
to enter text input mode press i
to delete you must press the escape key followed by x
to re-enter text press i key again and so on....

to save and quit the vi editor press the escape key then :wq enter/return
to quit vi without saving press escape :q! enter/return


Edit you fstab file to look like this:

/dev/hda2 swap swap defaults 0 0
/dev/hda1 / reiserfs defaults 1 1
/dev/hda3 /home reiserfs defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,user 0 0
devpts /dev/pts devpts gid=5, mode=620 0 0
proc /proc proc defaults 0 0

bruno buys 08-06-2004 05:57 PM

Gescom is right, "linux" is no filesystem name. This is why mount gives you the error msg. Follow what he says.
Pay attention to the "defaults" parameter, on your fstab. Yours is mistyped, now.


All times are GMT -5. The time now is 06:02 AM.