LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Partition Problem (https://www.linuxquestions.org/questions/linux-newbie-8/partition-problem-64854/)

ximian 06-10-2003 05:47 PM

Partition Problem
 
Hi, I am new to Linux and need some help.

I have installed RH9.0 on an 80GB HDD. I currently have WinXP on the first Partition, BUT I have an unallocated portion of the HDD that I am unable to allocate to Fat32 or vFat.

If you were looking at Grub this is what it would like at the present time, keep in mind the drive sequence may be different than noted here. BOOT/SWAP would be bound to partition1 boot table.

This is the working verion as I type this post out. BUT I am confused with the unallocated space. What can I do?
hd1 - Fat32 - 40006MB - Sector/Sector
hd2 - Free Space - 36311MB - Sector/Sector
hd3 - Boot - 102MB - Sector/Sector
hd4 - Swap - 1537MB - Sector/Sector
hd5 - Root - 9005MB - Sector/Sector

The italicizes is what I have concerns with. It is available BUT unable to allocate it under admin tools in XP or FDISK using floppy or boot-able XP disk.

Anything below here does not work...
What I would like to accomplish is to get this FREE space allocated to FAT32 so that I can share files between XP/Linux. I have tried several options as create three partitions one specifically for Linux.

Scenerio #1
+XP FDISK
+Partition1 - 40006MB
+Partition2 - 36311MB
+Unallocated - 10645MB
+Free Space - 8MB (Stupid MS)

+Reboot into GRUB
+Allocate the 10645MB of space to Linux.
+102 BOOT
+1537 SWAP
+9005 ROOT


Now that I have specified the ROOT partition the partition table goes wacky on me. After I edit the available space on the HDD, I get and error stating, "the partition table on the bios is corrupt if you to choose ignore it may ruin my partition BUT it may be fixable". Sooo I choose ignore. NOW after selecting Ignore GRUB gives me this and adds the root, initially specified for 9005MB, to <1!

+Free Space - <1MB - Sector/Sector
+hd1 - Fat32 - 40006MB - Sector/Sector
+Freespace - 1MB - Sector/Sector
+Freespace - 36311MB - Sector/Sector
+hd3 - Boot - 102MB - Sector/Sector
+hd4 - Swap - 1537MB - Sector/Sector
+hd5 - Root - <1 - Sector/Sector
+Freespace - 9005MB - Sector/Sector (ROOT should have been allocated here!)
+Freespace - <2 - Sector/Sector


Ok?!.... I delete the ROOT again and specify it to partition on the Freespace for 9005MB... again it defaults back to <1.

I have tried partitioning with several possibilities Floppy WIN98 Fdisk, Western Digital HDD Fdisk/Partitioning Utilities and XP Fdisk..

So now I am stuck with 36311MB of Unallocated FREE space I am unable to format or allocate to the system. BUT everything is running fine. GRUB boot loader works well and both systems are in working order.

How can i get this unallocated FREE space to become available OR how can I install RH9.0 on my HDD with 3+partitions without getting these allocations of <1MB. ROOT always defaults to <1 from what I have experienced I see no way out.

HELP !
:scratch:

ximian 06-10-2003 05:47 PM

Anyone understand whats going on? Did I explain it clearly...

Thymox 06-10-2003 05:55 PM

If your system boots into Linux fine, could you do the following for me, just to make things a little clearer? Open up a terminal and change to the root user (su root) and then type fdisk -l /dev/hda
Copy and paste the output here (you could put it inside [ code ] boxes so that it format nicely). Thanks.

ximian 06-10-2003 10:21 PM

Some reason I believe this may be incorrect. Any reason as to why the file can not be found? Remeber I am running RedHat 9.0 Kernal 2.4.20-18.9

Code:

[user@localhost user]$ su root
Password:
[root@localhost user]# fdisk -l /dev/hda
bash: fdisk: command not found
[root@localhost user]#



Rick422 06-11-2003 02:14 AM

It is late tonight so I have not bothered to carefully read all that you have posted. But, based on what I skimmed over, I have a few comments. It looks like you have 4 partitions already and are trying to create a 5th partition from the unallocated space. Most likely the 4 partitons that you already have are primary partions. Harddisks can only have 4 primary partions. If 4 primary partitions exist it is not possible to create a 5th partition of any type on just one harddrive. To create more than 4 partitons on one harddrive, one of the exiting primary partitions would have to be deleted and replaced with an extended partion. Once the extended partiton is created almost any reasonable number of logical partitions can be created within the extened partition.

Most operating systems such as DOS, Windows and probably FreeBSD can only be booted from a primary partions. They can however store programs and data on logical partitons. Most versions of Linux apparently can boot from either a primary or logical partition. The swap file can defiantely be placed on a logical partition.

I am not sure how your partiton table became corrupted. I did not realize that a partiton table could be stored in the BIOS, I always assumed the partition table was on the hard disk but maybe I am wrong about that. I am not sure what it would take to correct that or if perhaps you could just live with that slight problem. On my old computer I once had a harddisk that had problems with the partition table and other things. My other harddrive did not have that problem. I later replaced that hardrive with a larger one.

I have done most of my partition resizing, deleting, moving, copying and creating using either System Commander or Partition Magic. I also like the Disk Druid tool that comes with Red Hat 9 and is an optional way to create, delete and format partitions and choose mount points. I have only occasionally used fdisk or similar tools and have not used them often enough to get comfortable with them. Most Linux users use fdisk or cfdisk. Some users on this forum have expressed their dislike for Partiton Magic by the way.

I did not read all of your message very carefully. Did I correctly understand your current setup and what you are trying to do?

michaelk 06-11-2003 07:43 AM

To mount your FAT32 partition you will need to add an entry to your /etc/fstab file.

Quote:

This is the working verion as I type this post out. BUT I am confused with the unallocated space. What can I do?
hd1 - Fat32 - 40006MB - Sector/Sector
hd2 - Free Space - 36311MB - Sector/Sector
hd3 - Boot - 102MB - Sector/Sector
hd4 - Swap - 1537MB - Sector/Sector
hd5 - Root - 9005MB - Sector/Sector
Basic partition info.
You can only have 4 primary parititions i.e hda1-4.
You can have 64 logical parititions i.e. >= hda5
An extended paritition is a primary partition which is a container for logical partitions.

So how is your drive parititioned now?

use this to logon as root
su -

try:
/sbin/fdisk -l /dev/hda

ximian 06-12-2003 03:17 PM

Code:

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
  Device Boot    Start      End    Blocks  Id  System
/dev/hda1  *        1      5100  40965718+  c  Win95 FAT32 (LBA)
/dev/hda2          8372      8385    112455  83  Linux
/dev/hda3          8386      8581  1574370  82  Linux swap
/dev/hda4          8582      9729  9221310    f  Win95 Ext'd (LBA)
/dev/hda5          8582      9729  9221278+  83  Linux

Secotor 5101 - 8371 is what I would like to partition to FAT32 but unable to allocate it.

I had also created an extended and logical partitions thinking that should work. BUT after I had booted into GRUB between each partitions there was a space of <1 MB. I added the boot/swap then attempted to allocate the root to only 9MB BUT for some odd reason this would default to one of the smaller partitions on <1. I tried to proceed from there but the installer told me there is not enough free space to continue?!

No.. I do not use PM I dread that program.

J.W. 06-12-2003 04:28 PM

Dude, I don't think I can help you with your partition issues, but regarding your question about a previous question you posted but don't remember, just use the Search functionality on this site. If you remember the title, you can search on it, alternatively you can do searches based on User ID's. -- J.W.

michaelk 06-13-2003 09:03 PM

Well you could gnu parted to resize hda1 and just make it bigger. I have never tried to reclaim space in the middle.

I don't have any other solutions besides PM or starting over and repartition and reinstall linux.

ximian 06-14-2003 04:07 AM

I will be more than willing to delete the partitions windows is NOT on and reinstall RH again. No big deal to me atm.

I could also Ghost my first partition with XP on it and repartition, but from what I have seen so far is that between each partition I make either with XP fdisk, WIN98 fdisk or the exe file from Western Digital, I will see <1MB Free Space between each one. I do not understand why GRUB would show these and then when you specify where you want ROOT to go it would default to the smallest block on the hard drive being <1MB.

Anyone have an idea of why GRUB shows <1MB between partitions after you specify ROOT?

ximian 06-16-2003 04:48 PM

bump


All times are GMT -5. The time now is 08:58 PM.