LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Partition on Laptop does not work (https://www.linuxquestions.org/questions/linux-newbie-8/partition-on-laptop-does-not-work-75490/)

xmeson 07-24-2003 09:39 AM

Partition on Laptop does not work
 
I have just made the switch to linux and dumb enough to go the Slack way. My laptop has S2D partition from from manufacturer. However when i install linux everthing works well from image boot disks i have made [BARE.I] and roots [Install.1 & 2]. The fdisk seems to work well and everthing else goes as planned but when i reboot .

The Linux loader - i think says the partition is invalid and set up cannot continue. I tried to use the cfdisk and run the process again this time make the first swap [64M] bootable, at startup it returns that the S2D partition signature is not found and set up cannot continue.

Linux cannot help me with the system accepting Linux partitions - at least so says the help file in the setp. So what exactly can help?

fancypiper 07-24-2003 10:22 AM

If you are attempting to dual boot Microsoft and Linux, you need to re-size your partition first, but you didn't say that. I will assume you are going to run Linux only on it.

I'm not familiar with slack, but if I have ever had a Microsoft filesystem on a hard drive, I wipe it clean first by zeroing out the drive.

If you can get to a bash shell prompt, zero out the drive. I'm not familiar with laptops either, so I will assume that the drives are connected ide1 and 2, master and slaves as a tower.

Assuming one drive on ide1 master is your drive, give this command:

dd if=/dev/zero of=/dev/hda

This will write zeros on the drive, removing mbr and all, giving you a clean, unformatted drive, just as it would have come out of the box.

If you can't boot to a prompt, one of these should allow you to.

KNOPPIX Linux Live CD
Tom's Root and Boot floppy

xmeson 07-25-2003 03:46 PM

Partition Problem persists!
 
I intend to run only linux - Slack - on my private laptop, I have tried this command

dd if=/dev/zero of=/dev/hda

After running it says there is no more space on the drive.

I am able to boot up to the hash prompt even without the correct non linux partition. I use on of the floppy images that directly allows me boot the CD ROM.

However after using the above command, everything seems to still work, I mean installation and all.

I am not able to configure the system though my assumption is that. It is auto config., i.e the default kernel is auto loaded to the Hard Disk.

This time when the system is started again it says first that it cannot find a valid S2D partition! This i assume comes from the manufacturers BIOS, since the system was most likely made for windows.

But after this it just stops. It shows system specs and just stops!

One more thing, i cannot set the root password, it says no file or such directory exists!

fancypiper 07-25-2003 04:19 PM

I don't quite understand your post. Does it boot into something that looks like this?
Code:

Red Hat Linux release 7.3 (Valhalla)
Kernel 2.4.18-3 on an i686

tinwhistle login:

If so, it boots into linux.

Did you set a root password during install or are you supposed to do it now? Some distros don't set it during install, so you must do manually. At the prompt, enter root and press enter when asked for the passwork. Now, you should be root. Then use the command

passwd

and set the new password. If is says command not found, you must haven't installed somehing.

xmeson 07-26-2003 07:15 AM

It boots into something like this
____________________________
Pentium II MMX [CPU]
200MHZ
____________________________

That is all.

It does not give the prompt to login.

I am trying to say that with slackware you set up the root password during set up and it says, something like this

chroot: .....

File or directory does not exist.

I go on and complete the installation anyway.

This message was of this sort before i zeroed the hda;
____________________________
Pentium II MMX [CPU]
200MHZ
Invalid partition. set up cannot continue.
____________________________


All times are GMT -5. The time now is 05:49 AM.