-   Linux - Newbie (
-   -   Partition issue...relatively minor (

LinuxNoobX 01-25-2012 04:21 AM

Partition issue...relatively minor
Currently I have 5 partitions (I cannot delete or resize 4 of them because one or both OS's would not boot then).

Adjacent to the primary Linux part is about 40 gigs of unallocated space that I want to allocate to the primary Linux part next to it and then add a small swap part after. The primary Linux part will not resize to take up the unallocated space and I had no idea if it would work but I tried to make a new part with the unallocated and then try to merge the new part with the primary but when I try to create the new part I get an error message stating I have exceeded the maximum number of parts.

Currently I am using Parted Magic on a live usb to try and resolve the issue.

I thought about removing the unnecessary oem and recovery parts for the other OS BUT I do not know if the other OS would boot then. Z/Z

catkin 01-25-2012 10:06 AM

Were you able to resolve the issue with Parted Magic?

johnsfine 01-25-2012 10:13 AM

It is hard to give good advice when we don't know the situation. Show us the output from the following command as root
/sbin/fdisk -l


Originally Posted by LinuxNoobX (Post 4583869)
The primary Linux part will not resize

That is probably because it was mounted at the time. You can't resize a mounted partition. You were unclear about what was booted and what was mounted when you tried that resize.


Originally Posted by LinuxNoobX (Post 4583869)
then add a small swap part after.
I thought about removing the unnecessary oem and recovery parts for the other OS BUT I do not know if the other OS would boot then.

If your Linux partition is a primary partition, changing the number of primary or extended partitions before it would change its identity, which would be very complicated to clean up

If the unpartitioned space from which you want to create a swap partition is not inside an extended partition, then the fact that you have the max number of primary/extended partitions already will be an obstacle.

Those issues can be explained with less abstraction after we see the existing partition table.

LinuxNoobX 01-25-2012 10:40 AM

One minor problem... I am used to executing commands from root and not elevating them to root :) I switched from BT to Mint because BT doesn't support my usb modems ( I know what you are thinking BUT... BT 5 doesn't support the modems but BT 2 and 3 did... so BT 5 deliberately doesn't support my modems )... and I spent many months researching how to enable the modems and came upon with 101 guesses about how to do so but no conclusive answers. Also I think the forum mods (at BT) hate me... they used to slap me with infractions for saying stuff like "what the hell!"...

That and I hated switching between OS's if I felt like having a break and watching some bleach or something. BT5 is VERY secure... long story long I am using Mint now and have no idea how to elevate beyond sudo. Z/Z

johnsfine 01-25-2012 11:18 AM


Originally Posted by LinuxNoobX (Post 4584119)
have no idea how to elevate beyond sudo.

sudo is OK.

I'm guessing fdisk is in /sbin. If it is elsewhere or missing, you need to find it or maybe install it (or figure out which program you do have that gives you a copy/pasteable list of partition info).

If fdisk is in the usual place you can

sudo /sbin/fdisk -l

LinuxNoobX 01-25-2012 11:25 AM

25 mins... how far I am into house right now ( noting because my memory is uber crappy ). I'll switch over to Mint and search for fdisk info. Brb Z/Z

LinuxNoobX 01-25-2012 11:38 AM

got it...sorta
not sure about incompatibility between gedit and wordpad but the formatting (document structure not drive structure) looks a little odd but here it is:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x8d2a4582

Device Boot Start End Blocks Id System
/dev/sda1 16065 192779 88357+ de Dell Utility
/dev/sda2 * 206848 30926847 15360000 7 HPFS/NTFS/exFAT
/dev/sda3 30926848 361762815 165417984 7 HPFS/NTFS/exFAT
/dev/sda4 361764862 537542655 87888897 5 Extended
/dev/sda5 361764864 400824319 19529728 83 Linux
/dev/sda6 400826368 537542655 68358144 83 Linux

EDDY1 01-25-2012 12:19 PM

Linux is on extended partition,you have to resize the extended (sda4) before you can resize or move (sda5 or sda6).

LinuxNoobX 01-25-2012 12:28 PM

Sounds easy enough to do but if grub gets picky about partition location or size I will probably lose Linux and the other OS in one shot but a deletion or all Linux parts with Parted Magic followed by an immediate reinstall of Mint will probably work.

I love experimentation more than you will ever know BUT I have spent several weeks tweaking the crap out of the other OS and almost have it running as smooth as I like. (The valid registry entries to disable the UAC prompts can be very hard to find) Z/Z

EDDY1 01-25-2012 12:30 PM

Is the unallocated space after the linux extended partition?

EDDY1 01-25-2012 12:36 PM

Oh btw I made a misrepresentation when I said you have to resize extended first.
If resizing larger extended must be done first.
If resizing smaller the partitions within the extended must be done first.

LinuxNoobX 01-25-2012 12:37 PM

I'll explain the configuration after the other OS's parts... first is the logical, then primary and after that is the unallocated space. Z/Z

Edit: Originally it was logical, primary, swap and unallocated. I used parted magic to add swap to primary with the intent of adding unallocated to primary after that and then recreating the swap but after the swap was added to primary the unallocated could not be added to primary. Z/Z

EDDY1 01-25-2012 01:40 PM

I assume that you're referring to the unallocated space before sda1?
Also the space between sda1 & sda2?
You already have 4 primary partitions

You can easily use gparted live & move sda1 to the left
then sda2 to the left
also sda3 to the left
resize sda4 to the left, putting unallocated within sda4
then you have option of resizing or moving sda6 to the left & dealing with sda7
I have also done this on my machine & haven't had a problem, on my system I had to resize my / partition, which I did by resizing my home & in some cases I've actually taken the space from swap.


Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x34fe34fd

Device Boot Start End Blocks Id System
/dev/sda1 63 6554519 3277228+ 12 Compaq diagnostics
/dev/sda2 6554520 48789404 21117442+ c W95 FAT32 (LBA)
/dev/sda3 48789502 312580095 131895297 5 Extended
/dev/sda5 291344384 312580095 10617856 83 Linux
/dev/sda6 * 48791552 51400703 1304576 83 Linux
/dev/sda7 51402752 68073471 8335360 83 Linux
/dev/sda8 68077568 73934847 2928640 83 Linux
/dev/sda9 73938944 80945151 3503104 82 Linux swap / Solaris
/dev/sda10 80984064 81762303 389120 83 Linux
/dev/sda11 81764352 291338239 104786944 83 Linux
My / partition being sda6

LinuxNoobX 01-25-2012 02:07 PM

UnfortunatelyI don't know squat about grub and how it would react to me moving parts around be I do know if grub doesn't see Linux the grub resque prompt comes up and I have to reconfigure the lappy's 2 OS's from scratch...very time consumming (esspecially the butterfly).

In order to get a workable configuration I stuck with what I knew. Since win and Linux can easily access files from c: I expanded it to all but 40 gigs. Leaving 15 for logical(/ or root), 20 for primary (/home) and 5 for swap.

It's not a pretty or elegant solution but it is a solution I have faith in.

I am in the middle of the Mint install right not. If I want to experiment with partitions later I can use one of my netbooks.

Thanks for your help everybody. Z/Z

EDDY1 01-25-2012 02:18 PM

Congrats on your solution

All times are GMT -5. The time now is 06:06 AM.