LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-18-2011, 12:05 PM   #1
Skyer
Member
 
Registered: Aug 2011
Posts: 113

Rep: Reputation: 6
Pacman cannot satisfy dependencies because of missing libgl


Hello,

I am using AMD catalyst driver, which should be sufficiend replacement for libgl. However, as multiple packages depend on libgl, I can't update the system. Are there any workarounds, or some way to solve this problem?

Code:
[root@sigma skyer]# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
warning: removing 'libgl' from target list because it conflicts with 'catalyst-utils'
error: failed to prepare transaction (could not satisfy dependencies)
:: intel-dri: requires libgl=7.11.2
:: mach64-dri: requires libgl=7.11.2
:: mga-dri: requires libgl=7.11.2
:: r128-dri: requires libgl=7.11.2
:: savage-dri: requires libgl=7.11.2
:: sis-dri: requires libgl=7.11.2
:: tdfx-dri: requires libgl=7.11.2
Thank you for your time,

Skyer
 
Old 12-18-2011, 01:54 PM   #2
headrift
Member
 
Registered: Sep 2005
Distribution: Gentoo, Sabayon, Puppy, Arch
Posts: 165

Rep: Reputation: 29
Are you using those packages? I'm guessing you have an AMD card, which means those other *-dri packages shouldn't be needed. What happens when you try to remove them?
 
Old 12-18-2011, 01:57 PM   #3
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 73
None of those are required for your video card, they can be safely removed.
 
Old 12-18-2011, 02:15 PM   #4
Skyer
Member
 
Registered: Aug 2011
Posts: 113

Original Poster
Rep: Reputation: 6
Alright, worked.

I admit I do not exactly understand this graphics card drivers stuff.

Thanks for help, problem solved.


Skyer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does Arch break if pacman tracks dependencies? Mr. Alex Arch 4 11-22-2012 06:59 PM
Can't satisfy wxpython python2.4 dependencies - rpm database problem? mfurnanz Linux - Newbie 3 01-17-2007 04:46 AM
Missing libGL.so.1 doctorwebbox Debian 12 04-14-2005 02:00 PM
pacman problem, missing current ylikone Arch 3 12-17-2004 06:30 PM
unable to satisfy dependencies ??? belkins Linux - Newbie 2 10-18-2004 04:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration