LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2005, 10:31 AM   #1
stickygreen
LQ Newbie
 
Registered: Jan 2005
Location: florida
Distribution: FC3 / Slackware 10
Posts: 7

Rep: Reputation: 0
P2P help


first .. sorry if i'm duplicating threads ... i'm a nOOb

i'm using FC3 and trying to get limewire working
i've gotten limewire installed .. and i know i have java properly install as azureus works fine
when lime loads i get the splash screen and the console in the backgroud showing jre loading .. then a bunch of text scrolls
then everything goes to desktop before i get a chance to read what's in the console
i'd like to try and fix this myself and i'm hoping someone may nudge me in the right direction
is there a log file i can look at to see what my problem might be or something ?

don't know if this helps but i'm using gnome desktop

any help will be appreciated
thanks

Last edited by stickygreen; 02-12-2005 at 10:34 AM.
 
Old 02-12-2005, 10:58 AM   #2
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
open the console first... then try and run limewire -- that way all the warnings/errors will still be there when lw dies
 
Old 02-12-2005, 11:08 AM   #3
stickygreen
LQ Newbie
 
Registered: Jan 2005
Location: florida
Distribution: FC3 / Slackware 10
Posts: 7

Original Poster
Rep: Reputation: 0
thanks
that kept the console open ..... now i just have to figure out what it all means
 
Old 02-12-2005, 12:49 PM   #4
stickygreen
LQ Newbie
 
Registered: Jan 2005
Location: florida
Distribution: FC3 / Slackware 10
Posts: 7

Original Poster
Rep: Reputation: 0
i've been trying for almost 2 hours to get lime running
the only error message i see in terminal is this
UIDefaults.getUIError: failed to locate UI class:TextAreaUI
can anyone shed some light on this ? .... googling didn't bring much up on this

thanks
 
Old 02-12-2005, 07:07 PM   #5
caps_phisto
Member
 
Registered: Sep 2004
Location: NH
Distribution: FC6, FC1-4, RH9, Gentoo 2006.0/1, Slackware 10.1/2,11, Vector SOHO 5.0.1
Posts: 237

Rep: Reputation: 30
Are you using the JRE or the JSDK? I am using JSK 1.4.2-06 and LimeWire runs great. It looks like LimeWire is looking for a Class in the Java libraries that you don't have...I would suggest downloading and installing Java again.
 
Old 02-12-2005, 07:13 PM   #6
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
Also you may want to check that the java files are in your path. Its possible the classpath (which tells java where all its library files are) is not set and so it can't find out the files it needs to draw a Text area.

HTH

Alex
 
Old 02-13-2005, 10:56 AM   #7
stickygreen
LQ Newbie
 
Registered: Jan 2005
Location: florida
Distribution: FC3 / Slackware 10
Posts: 7

Original Poster
Rep: Reputation: 0
i installed j2se 5.0
i'll uninstall and install j2se 1.4.2sdk and see if that fixes the problem

thanks for the help
 
Old 02-15-2005, 08:28 AM   #8
knl
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Rep: Reputation: 0
When tryimg to run Limewire run it with the command strace in font of it this may help you debug.

Example
strace ./limewire
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
p2p ???? unionjak SUSE / openSUSE 5 10-17-2005 11:40 AM
about p2p yoursmile Linux - Newbie 3 07-10-2005 08:27 PM
Risk of Linux P2P vs. Windows P2P software snatale1 Linux - Software 2 12-04-2004 07:14 PM
p2p? Virtualhate Linux - Newbie 7 06-29-2004 10:30 PM
can some someone say P2P? ouibouy Linux - Software 16 03-20-2003 04:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration