LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-27-2010, 08:53 AM   #1
demanet
LQ Newbie
 
Registered: Sep 2010
Location: Warwick, UK
Distribution: Debian
Posts: 18

Rep: Reputation: 4
OS not found


hi,
i've just installed linux mint debian on a samsung N210 netbook that had windows 7, chose to use entire disk, went through and completed the installation, removed the USB stick, restarted as prompted and am getting the message Operating System not found. i created the boot stick using unetbootin. i'm using the same netbook right now on the live USB. when you post your answer keep in mind you're talking to a newbie so make it simple..... please
 
Old 10-27-2010, 09:23 AM   #2
Expeto
Member
 
Registered: Sep 2010
Posts: 30

Rep: Reputation: Disabled
hmm, most interesting.

Did you done anything with your bios, like tweaking it for USB boot? Maybe your bios looks at the wrong place for an OS. Try resetting the bios or manually changing first boot device to HDD.
 
Old 10-27-2010, 09:46 AM   #3
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,298

Rep: Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386
If setting the BIOS to boot first from the hard drive does not help, open a terminal from the Mint on USB and get your partition information with this command to post here:

sudo fdisk -l(Lower case letter L in the command)
 
Old 10-27-2010, 10:56 AM   #4
demanet
LQ Newbie
 
Registered: Sep 2010
Location: Warwick, UK
Distribution: Debian
Posts: 18

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by yancek View Post
If setting the BIOS to boot first from the hard drive does not help, open a terminal from the Mint on USB and get your partition information with this command to post here:

sudo fdisk -l(Lower case letter L in the command)
Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0003f82b

Device Boot Start End Blocks Id System
/dev/sda1 1 1276 10240000 82 Linux swap / Solaris
/dev/sda2 1276 2551 10240000 83 Linux

Disk /dev/sdb: 2002 MB, 2002747392 bytes
32 heads, 63 sectors/track, 1940 cylinders
Units = cylinders of 2016 * 512 = 1032192 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3efb2c27

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 1940 1955488+ b W95 FAT32
 
Old 10-27-2010, 11:04 AM   #5
demanet
LQ Newbie
 
Registered: Sep 2010
Location: Warwick, UK
Distribution: Debian
Posts: 18

Original Poster
Rep: Reputation: 4
thanx EXPETO
i changed it to boot from the HDD and that did not work. i have just pasted the fdisk result above as requested by yancek
 
Old 10-27-2010, 11:14 AM   #6
fbobraga
Member
 
Registered: Jul 2010
Location: São Paulo - Brasil
Distribution: Debian 7 / Crunchbang 11
Posts: 229

Rep: Reputation: 41
your /dev/sda1 is not marked as bootable (wow, if Mint setup left that, it's a huge flaw!)

You can fix it with the liveCD you are on now with: http://forums.linuxmint.com/viewtopi...=57480#p328994

* Please use [code] tags around outputs posted - without it, it's barely readable

Last edited by fbobraga; 10-27-2010 at 11:19 AM.
 
Old 10-27-2010, 11:18 AM   #7
demanet
LQ Newbie
 
Registered: Sep 2010
Location: Warwick, UK
Distribution: Debian
Posts: 18

Original Poster
Rep: Reputation: 4
thanx
to be honest i doubt that mint would have made such a mistake. i may have messed up the installation. i just need to know how i could fix it please
 
Old 10-27-2010, 11:23 AM   #8
fbobraga
Member
 
Registered: Jul 2010
Location: São Paulo - Brasil
Distribution: Debian 7 / Crunchbang 11
Posts: 229

Rep: Reputation: 41
if you used the DOS tool fdisk, try to use
Code:
sudo cfdisk
in a terminal (to set the boot flag - it's almost identical the old DOS fdisk)

* the partition you need to set the boot flag is /dev/sda2 (in your case)

Last edited by fbobraga; 10-27-2010 at 11:26 AM.
 
Old 10-27-2010, 11:24 AM   #9
udaman
Member
 
Registered: Oct 2010
Location: New England, USA
Distribution: OpenSUSE/Slackware64/RHEL/Mythbuntu
Posts: 187

Rep: Reputation: 39
Quote:
Originally Posted by demanet View Post
Device Boot Start End Blocks Id System
/dev/sdb1 * 1 1940 1955488+ b W95 FAT32
That disk is marked as a boot disk see the * next to /dev/sdb1. You need to do that for /dev/sda2 also

as root start fdisk with

Code:
fdisk /dev/sda
Then set the partition bootable. Here's the sequence I would use, except I'm showing /dev/sdc, you want to use /dev/sda and make /dev/sda2 bootable.

Code:
me@boreal:~> sudo fdisk -cu /dev/sdc


Command (m for help): m
Command action
   a   toggle a bootable flag
   b   edit bsd disklabel
   c   toggle the dos compatibility flag
   d   delete a partition
   l   list known partition types
   m   print this menu
   n   add a new partition
   o   create a new empty DOS partition table
   p   print the partition table
   q   quit without saving changes
   s   create a new empty Sun disklabel
   t   change a partition's system id
   u   change display/entry units
   v   verify the partition table
   w   write table to disk and exit
   x   extra functionality (experts only)

Command (m for help): a
Partition number (1-4): 1

Command (m for help):
That may not be your only problem, but it's worth a try.
 
Old 10-27-2010, 11:28 AM   #10
demanet
LQ Newbie
 
Registered: Sep 2010
Location: Warwick, UK
Distribution: Debian
Posts: 18

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by fbobraga View Post
if you used the DOS tool fdisk, try to use
Code:
sudo cfdisk
in a terminal (to set the boot flag - it's almost identical the old DOS fdisk)

* the partition you need to set the boot flag is /dev/sda2 (in your case)
working on it

Last edited by demanet; 10-27-2010 at 11:35 AM.
 
Old 10-27-2010, 12:40 PM   #11
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,298

Rep: Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386
It is not necessary to set the boot flag as active on Linux systems. Take a look at the link below, section 4.G, Installing Grub with grub-install. I would guess your Grub installation during the system install failed for some reason.

http://www.dedoimedo.com/computers/grub-2.html

The link is for Grub2, if you have Mint 8 or 9, it should be right.

Last edited by yancek; 10-27-2010 at 12:41 PM.
 
1 members found this post helpful.
Old 10-27-2010, 01:05 PM   #12
fbobraga
Member
 
Registered: Jul 2010
Location: São Paulo - Brasil
Distribution: Debian 7 / Crunchbang 11
Posts: 229

Rep: Reputation: 41
Quote:
Originally Posted by yancek View Post
It is not necessary to set the boot flag as active on Linux systems. Take a look at the link below, section 4.G, Installing Grub with grub-install. I would guess your Grub installation during the system install failed for some reason.

http://www.dedoimedo.com/computers/grub-2.html

The link is for Grub2, if you have Mint 8 or 9, it should be right.
@OP:
I think my directions were wrong. This may help with the above: https://help.ubuntu.com/community/Gr...ing%20GRUB%202

or you can use it: http://www.supergrubdisk.org/super-grub2-disk/ to boot the OS and just run
Code:
sudo grub-install /dev/sda

Last edited by fbobraga; 10-27-2010 at 01:06 PM.
 
1 members found this post helpful.
Old 10-28-2010, 08:04 AM   #13
demanet
LQ Newbie
 
Registered: Sep 2010
Location: Warwick, UK
Distribution: Debian
Posts: 18

Original Poster
Rep: Reputation: 4
i messed up a few things on the install so i formatted the hard disk and will re-install it and if i run into some problems i will paste the fdisk -l outcome here
thank you for your help
 
Old 10-28-2010, 11:43 AM   #14
demanet
LQ Newbie
 
Registered: Sep 2010
Location: Warwick, UK
Distribution: Debian
Posts: 18

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by fbobraga View Post
@OP:
I think my directions were wrong. This may help with the above: https://help.ubuntu.com/community/Gr...ing%20GRUB%202

or you can use it: http://www.supergrubdisk.org/super-grub2-disk/ to boot the OS and just run
Code:
sudo grub-install /dev/sda
i formatted the drive and installed mint 10..... same error: OS not found

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00043ca0

Device Boot Start End Blocks Id System
/dev/sda1 * 1 30020 241127424 83 Linux
/dev/sda2 30020 30402 3068929 5 Extended
/dev/sda5 30020 30402 3068928 82 Linux swap / Solaris

Disk /dev/sdb: 2002 MB, 2002747392 bytes
32 heads, 63 sectors/track, 1940 cylinders
Units = cylinders of 2016 * 512 = 1032192 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3efb2c27

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 1940 1955488+ b W95 FAT32

this is the result i got when trying to install grub:

sudo grub-install /dev/sda
grub-probe: error: cannot find a device for /boot (is /dev mounted?).
/usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).
 
Old 10-28-2010, 02:44 PM   #15
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,298

Rep: Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386
The last version of Mint I installed as Mint 7. At the end of the installation, there is an option in regard to installing the bootloader.
The default should be to install to the mbr of the first drive. Did you make any changes or choose to install it elsewhere? Why didn't you install the bootloader during the OS installation? Your output:

Quote:
sudo grub-install /dev/sda
grub-probe: error: cannot find a device for /boot (is /dev mounted?).
/usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).
Run the mount command: sudo mount
If you don't see sda1 in the output, you will need to mount it:
First, create a mount point: sudo mkdir /mnt/mint
sudo mount -t ext4 /dev/sda1 /mnt/mint

Then try the grub-install again. Don't really know if this will work but your error message is complaining about mount?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Directory not found; -xzvf not found; Makefile not found RealGomer Linux - Software 4 09-20-2010 10:02 AM
Fedora Core 6 boot No medium found No volume groups found awadhut Linux - Hardware 1 02-22-2007 01:15 AM
CDROM found/not found SUSE 9.2 dirdej SUSE / openSUSE 4 01-14-2005 11:58 PM
gcc vs. g++ -> iostream lib found vs. not found CooManChu Linux - General 1 12-11-2004 09:20 AM
PDC 20276 - Promise Fasttrack 133 found but still not found.. FransE Linux - Hardware 3 02-16-2004 07:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration