-   Linux - Newbie (
-   -   Oracle Unbreakable Linux 2.6.32 , Unable use WIFI, Atheros AR9285 (

RafaFrank 07-15-2012 08:20 PM

Oracle Unbreakable Linux 2.6.32 , Unable use WIFI, Atheros AR9285
Hello, I am new here, and just for advice, I am Brazilian, so in advance, sorry about my bad english.

The issue: Guys, I have downloaded Oracle Unbreakable Linux a time ago, and i've been trying to connect to internet using the WiFi device, without success, I have tryed a lot of Bash commands that I have found in tutorials of other distros(eg. Red Hat, Ubuntu, CentOS, Slack...). Since we tutorials about Oracle Linux are quite hard to find (for me at least).


Notebook ASUS A43E Series/ Core i5 2410M,2.3GHz / Mem. 6GB DDR2 / HDD 500GB Dualboot (Win7 and OUL)


uname -r



lspci -nn | grep Network

02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)


[root@rafafrank ~]# ifconfig
lo        Link encap:Local Loopback 
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:960 (960.0 b)  TX bytes:960 (960.0 b)

virbr0    Link encap:Ethernet  HWaddr 52:54:00:80:11:AC 
          inet addr:  Bcast:  Mask:
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:4299 (4.1 KiB)

virbr0-nic Link encap:Ethernet  HWaddr 52:54:00:80:11:AC 
          inet6 addr: fe80::5054:ff:fe80:11ac/64 Scope:Link
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:885 overruns:0 carrier:0
          collisions:0 txqueuelen:500
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


[root@rafafrank ~]# iwconfig
lo        no wireless extensions.

virbr0    no wireless extensions.

virbr0-nic  no wireless extensions.

Trying to set the stuff up

[root@rafafrank ~]# ifconfig virbr0 up
[root@rafafrank ~]# iwlist virbr0 scan
virbr0    Interface doesn't support scanning.

obs1: I have never used linux before...
obs2: I am a student, and I am trying to make this Notebook a server for an Oracle 11g DB, to test my Java programs... If this somehow is impossible, please say to me, and if possible say why it is impossible.

Thanks in advance! :D

hiero2 07-17-2012 11:27 AM

Oracle Unbreakable is based on RedHat. I installed a version of it some 4 or 5 years ago when I started, too. While Redhat, and Fedora, are very good, there may be issues that make your experience more difficult than necessary. I know I found issues with Oracle Unbreakable that were difficult to resolve.

My suggestion would be to change distros. The Oracle personal db versions are (or were) available in both rpm (Oracle U, Redhat, openSuse) and deb (Ubuntu, Debian, Mint) installation packages. That was 10i, I think. My 1st recommendation would be to go to Ubuntu. They have the best user support of any distro. The learning curve is much slower (this is good). My 2nd recommendation would be to try openSuse. I would do this if you can not get the 11g installation in a deb package. OpenSuse also has a good user base, and good help documentation. And, Opensuse uses the rpm installation packages. [By the way, for most packages, an rpm from one distro will not necessarily work in another distro, but for the Oracle 10 personal db this was not a problem. I assume it will be the same for 11g. I downloaded to my desktop, and listed my desktop in my repositories.]

My 3rd recommendation would be to switch to Fedora. Those three distros have big user bases, and thus plenty of experienced user help. I list Fedora last, because it is the bleeding edge distro for Redhat to experiment with. You may get bleeding edge problems you do not want. Outside of that, they do a fine job. As you have discovered, Oracle Unbreakable does not have a big user base to help you. They are also a step or two behind Redhat, and I have found that distros, even as recently as 5 years ago, were more prone to hardware issues for newbs than they are today. Even if Oracle is up-to-date, they will be "older", and thus will give you issues.

I'm running the 10 personal db on a Ubuntu 10.04 server.

RafaFrank 07-17-2012 03:25 PM


Thank you very much for the reply! Then I will try to run 11g on Ubuntu... I tough that using Oracle Linux should be the best distro to host an Oracle DB, but I was wrong...

Thank you again!

jefro 07-17-2012 03:36 PM

Not sure Oracle is the best but it is fully supported.

It is possible I believe to get that working but you have to understand that OUL is based on Red Hat and it's intended computer is a server.

What you might consider is a virtual machine. Then you don't need to care as the host OS would control the wireless. This might be your best bet. You pick a virtual machine application such as virtualbox, vmplayer or virtualPC or even some others. You then install an OS of your choice. Oracle used to offer a pre-made OUL and database already in a free virtual machine that can be downloaded. You just download it and boot it.

RafaFrank 07-18-2012 02:53 PM


Thank you for the reply!

hiero2 07-18-2012 03:54 PM

OUL is fully supported, true, but last time I looked, it was all pay support. And, as I pointed out, it has fewer users, which makes user support harder to find.

The Oracle databases will run on any linux box - the trick is to find a proper install package. In 2009 or 2010, I forget, I even used Alien to convert a deb package into a slack package for Vector. And, the db ran. I had other issues though, and so Vector didn't last for long.

I don't know about 11, but the personal version of 10 utilizes a gui interface, and a browser-based utility for db setup and management. This may be just for the personal version, but my impression is that this is standard for all the Oracle dbs now. It worked fine in Vector, which uses xfce, but I had to manually make the menu entries as the installation did not. OUL uses Gnome - so the install looks for that. Like Redhat, OUL uses rpm packages. Ubuntu also uses Gnome, so the menu entries and all that worked just fine for me in Ubuntu once I had a deb install package.

If RafaFrank switches to a distro that specializes in KDE, he will want to be aware that, while the installation should not be affected, it might be. I wouldn't expect anything except menu entry listing problems, though, like I had with xfce. The db still actually runs without a gui desktop, and if you know the command line commands, you can do whatever you like. The advantage in the gui browser-based utility is to assist with the learning curve.

RafaFrank 07-18-2012 04:19 PM


Thanks for the reply bro! 11g has also an Web based interface, and I have solved my problem using an DSL/Cable connection, instead of a WiFi one. I think that OUL haven't focused support to WiFi connections, just because (I think) that a WiFi server is kind of useless...

hiero2 07-19-2012 08:11 AM


Sometimes the workaround works better! Good on ya!

jessez 01-03-2013 08:40 AM


Just for general info since I just ran up against the same road-block with a new server that can only use a wireless card; The Oracle unbreakable kernel doesn't load the wireless extentions and doesnt even seem to have the ath9k, etc modules available to it.
If you boot the system into the alternate (standard kernel) that also gets installed by default in a fresh install, it will set-up wireless as normal.This remains true even after updating the system which at this point is pulling new kernels of both types.

If I figure out how to resolve this issue in a way that updating the kernel, kernel firmware and the modules themselves so the update doesn't break anything, or is a simple fix after an update, I will post my results and instructions here.

Best Regards and Happy New Year to all.

All times are GMT -5. The time now is 02:31 PM.