LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2011, 05:02 PM   #1
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 797

Rep: Reputation: 42
Optiplex GX520 & Debian Wheezey blue then black screen on boot


Ladies & Gents,

I have a small problem. I have acquired a Dell Optiplex GX520 (desktop) to replace an older p4 desktop (mini tower). The only live cd I can get to boot (default) is an old Cluster Knoppix disk that is running the 2.4 kernel, but it does not function very well. I was able to get the latest gparted live cd to boot using the manual setup and the vesa driver. Every other driver yields a blue screen that then goes black after the monitor gives up.

I did get Debian Wheezey (net install i-386) to install finally from the ncurses install but I am unable to boot the machine, even in single user mode and still be able to see anything except the blue-to-black screen.

The Optiplex GX520 has an "Intel GMA 950 Dynamic Video Memory Technology 3.0" according to the Dell specs.

So far google has not been much help.

I have passed vga=791 and vga=772 to the kernel with the same results.

There is no video or vga entry in the default boot line in grub2 just ro and quiet.

What should I pass to the kernel from grub2 to get it to boot so I can see it?


Also is there something I can change in the bios that would help? Seams not. I updated it to the most recent version from Dell with no joy. I still can't get any kind of boot that I can see after the, I think frame buffer, activates. At this point I don't know what to check.

Thanks
 
Old 12-26-2011, 07:08 PM   #2
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 267

Rep: Reputation: 49
I have tried many different Distros and the one that works well with any Dell that I have tried is Slackware. With slack you have the advantage of 9 different window managers with the full install, if KDE doesn't do it for you, just go to xfce of fluxbox or etc.

Last edited by zrdc28; 12-26-2011 at 07:09 PM.
 
Old 12-26-2011, 07:47 PM   #3
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 797

Original Poster
Rep: Reputation: 42
I don't really beleave that it is a windows manager issue since I can't even boot to a commandline as in single user mode.
 
Old 12-26-2011, 08:03 PM   #4
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 797

Original Poster
Rep: Reputation: 42
I do have a Slack 13 disk and it does boot ok from it. No graphical or anything but at least it comes up. So now the question is what is different about the slack install disk boot and the existing debian install.

Like I said, the only boot options on the install are ro and quiet.
 
Old 12-28-2011, 12:52 PM   #5
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 797

Original Poster
Rep: Reputation: 42
I opted to trade for a optiplex 755 that would run debian without having to hack it

all I had to do was swap the drives and reinstall both with xp.

I will be putting Wheezey64 on it in the next step
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian black screen on boot mikey6705 Linux - Newbie 2 10-04-2011 09:21 PM
boot black screen Debian jtag Linux - Software 3 04-24-2010 08:41 AM
Black screen on Dell Optiplex GX260 japhyr Linux - Newbie 5 12-02-2009 05:55 AM
Dual monitor for Intel 82915G & ATI Rage 128 card on FC6, Dell Optiplex Gx520 powah Linux - Hardware 0 01-08-2009 11:34 AM
After install, fedora starts, does startup, black screen with blue bar at top? SlashAxlX Fedora 1 03-22-2007 12:51 AM


All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration