-   Linux - Newbie (
-   -   "Operation not permitted" error logging in to Ubuntu Dapper Drake (

paulBottomley 08-09-2006 04:23 PM

"Operation not permitted" error logging in to Ubuntu Dapper Drake
Hi there, I'm fairly new to all this Linux business, Ubuntu doubly so, so I hope this is the right place to post this.

Whenever I try to log on, I think it does actually log me in, but then instantly logs me out again, dumping me back at the log in screen. This is what it says:


Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem or that you may be out of disk space. Try logging in with one of the failsafe sessions to see if you can fix this problem.
Now, I know I'm not out of disk space, and I don't want to have to reinstall if I can help it. Here's the output it generated on the same message box:


/etc/gdm/PreSession/Default: Registering you session with wtmp and utmp
/etc/gdm/PreSession/Default: Running: /usr/bin/sessreg -a -w /var/run/utemp -x "/var/lib/gdm/:0.Xservers" -h " " -l ":0" "[username]"
/etc/gdm/Xsession: Beginning session setup...
Could not set mode 0700 on private per-user gnome configuration directory `/home/paul/.gnome2_private/': Operation not permitted.
So I tried logging in at a failsafe terminal, and, as root, started X up. I guess I can't tear myself away from the GUI :) That gave me this message, which might very well be because I'm in a failsafe mode, I suppose, but I'll include it in case it's important:


Power Manager
This program cannot start until you start the dbus system service.
It is strongly reccomended you reboot your computer after starting messagebus.
I tried making .gnome2_private writable to all, which I know was a silly idea, but that just got me another error message before the first telling me it shouldn't be writable. That seems to conflict with the idea that it needs to perform an operation on it, but that's why I'm the noob and you guys are the experts.

I have no idea how to make it work, any advice is greatly appreciated, thank you

Agrouf 08-09-2006 04:37 PM

why not trying just to make it xritable only by the user?
chmod 700 .gnome2_private (as it seems to be trying to do)

IsaacKuo 08-09-2006 04:47 PM

Did you try to make /home a FAT partition? That "Operation Not Permitted" error is exactly the sort of error that would occur with a FAT partition because FAT doesn't support Unix style file permissions (like "700").

You need to make /home an ext3 or some other *nix style file system (like XFS, ReiserFS, etc.).

paulBottomley 08-09-2006 04:55 PM

Thanks guys,

I tried what you suggested, Agrouf, and felt like a bit of a fool when I read it :P
But alas, it comes up with the exact same message.

IsaacKuo, the drive is ext3, though I should probably have already mentioned, it's a seperate partition which already had quite a lot of stuff on it before I installed Ubuntu. I'm rather glad I didn't make it FAT32 now, as the thought did cross my mind when I made it :)

paulBottomley 08-10-2006 05:00 AM

Anyone else want to have a crack at it? At all?
Or should I just go back to FC? That worked okay, at least it let me log in.

IsaacKuo 08-10-2006 07:16 AM

If you're using an already existing /home, and the rest of the Ubuntu install was a clean install, then I'm guessing that the old /home had some different user and/or group numbers. Try doing this:

cd /home
sudo chown -R myuserid:mygroupid myuserid/

This will force everything in your home directory to be owned by you.

paulBottomley 08-10-2006 10:45 AM

Sorry to be a thickie, but... What are my userid and usergroup?

In any event, I solved the problem the nooby way of just reinstalling Ubuntu and mounting that partition as something other than /home. Now you're probably going to tell me I didn't need to reinstall, but at the time, after yonks of Windows-ness, it semmed logical :|

Thanks for all your help :)

IsaacKuo 08-10-2006 11:13 AM

In Linux as well as other Unix-like operating systems, each user and group is assigned numbers. On the ext3 file system, the owning user and group is stored by number, rather than name. If you install a new OS, the default user/group numbers might not be the same.

If you do a detailed file listing with "ls -l", then it will show the user:group by name, but the underlying data is actually the number. (It will actually only show the name if that number corresponds to an existing user/group. If not, then it will show the number.)

All times are GMT -5. The time now is 01:30 PM.