LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   openvpn : Initialization Sequence Completed but my ip was not changed (https://www.linuxquestions.org/questions/linux-newbie-8/openvpn-initialization-sequence-completed-but-my-ip-was-not-changed-948058/)

J.A.X 06-01-2012 07:23 PM

openvpn : Initialization Sequence Completed but my ip was not changed
 
Hello all,

I'm running F17, I've an openvpn installed and configured ( I think ) as it should, my problem is that when I issue the command :

PHP Code:

openvpn /etc/openvpn/service.config 

I get " Initialization Sequence Completed "

but when I try to surf the internet using my pre-installed firefox my IP (as google says is the smae) still the same.

I've tried to change firefox settings to proxy 127.0.0.1 prot 1194 (openvpn port)

and I got proxy refusing the connection messege

I'm not even sure whats my problem is it openvpn is not configured properly or I'm not configuring proxy setting on firefox properly.

please help

J.A.X 06-02-2012 07:50 AM

this is my server.conf file

PHP Code:

########################################
# Sample OpenVPN config file for
# 2.0-style multi-client udp server
#
# Adapted from http://openvpn.sourceforge.net/20notes.html
#
# tun-style tunnel

port 1194
dev tun

# Use "local" to set the source address on multi-homed hosts
#local [IP address]

# TLS parms
tls-server 
ca 
/etc/openvpn/keys/ca.crt
cert 
/etc/openvpn/keys/server.crt
key 
/etc/openvpn/keys/server.key
dh 
/etc/openvpn/keys/dh1024.pem

# Tell OpenVPN to be a multi-client udp server
mode server

# The server's virtual endpoints
ifconfig 10.8.0.1 10.8.0.2

# Pool of /30 subnets to be allocated to clients.
# When a client connects, an --ifconfig command
# will be automatically generated and pushed back to
# the client.
ifconfig-pool 10.8.0.4 10.8.0.255

# Push route to client to bind it to our local
# virtual endpoint.
push "route 10.8.0.1 255.255.255.255"

# Push any routes the client needs to get in
# to the local network.
push "route 192.168.0.0 255.255.255.0"

# Push DHCP options to Windows clients.
push "dhcp-option DOMAIN example.com"
push "dhcp-option DNS 192.168.0.1"
push "dhcp-option WINS 192.168.0.1"

# Client should attempt reconnection on link
# failure.
keepalive 10 60

# Delete client instances after some period
# of inactivity.
inactive 600

# Route the --ifconfig pool range into the
# OpenVPN server.
route 10.8.0.0 255.255.255.0

# The server doesn't need privileges
user openvpn
group openvpn

# Keep TUN devices and keys open across restarts.
persist-tun
persist
-key

verb 4 

I'm connected via usb mDSL (Mobile Broadband) as NetworkManger sees it.

jimimick 06-04-2012 10:15 PM

I believe you need:
Code:

push "redirect-gateway def1"
in there to forward all traffic through the vpn.

source: *cant post a url until first post*openvpn*cant post a url until first post*net/index.php/open-source/documentation/howto*cant post a url until first post*.html

I only found this because I have the exact same problem but i do have this in my config file, please tell me if you found anything else wrong or another way you fixed it.

jimimick 06-05-2012 10:52 AM

Hi, I found the problem if anyone else is stuck too, you can only "push" server to client so you need
Code:

redirect-gateway def1
in the client config file.


All times are GMT -5. The time now is 11:07 AM.