-   Linux - Newbie (
-   -   OpenSUSE x86_64 does not mount /dev/tape (or /dev/st0 or /dev/nst0) (

yankeeinga 08-20-2008 10:13 AM

OpenSUSE x86_64 does not mount /dev/tape (or /dev/st0 or /dev/nst0)
Hello everyone.

I tried looking in the forum archives but have not been able to find an answer for my question that matches my setup.

I am running OpenSUSE x86_64 on a Dell Poweredge SC 1435. I am trying to access an Ultrium2 LTO tape drive attached to a SCSI port. As far as I can tell, the SCSI driver is not detecting the drive and /dev/tape, /dev/st0 and /dev/nst0 are not being created. I have installed the rpms for mtx and mt_st, yet the server seems completely unable to detect and mount the drive. I believe the SCSI card is pretty generic -- an Ultra320 SCSI Host Adapter.

I am completely at a loss as to how to get it up and running. I'm usually a home user and have had no need for a tape drive. I'm also more of a programmer than a sysadmin. Any guidance would be greatly appreciated.



bigrigdriver 08-20-2008 12:32 PM

Let's find out if the tape drive can be detected. In a console, run 'hwinfo --tape' (without quotes). Hwinfo should identify the tape drive, tell you which driver is needed, what device file it uses, and whether or not the driver is active.

What return do you get from the hwinfo command?

yankeeinga 08-20-2008 12:46 PM

Thanks for helping.

I feel kind of silly as I've been using Linux for years. I feel like I should know better.

Anyhow, running hwinfo from the command line , the program flashes a few lines of text (that are too fast to read) and then returns nothing. When I run it with the --log file option, grepping for 'tape' returns the following:

>>scsi.2 scsi tape
sysfs: no such class: scsi_tape

So I think I can assume that the OS can't find the tape drive.


yankeeinga 08-20-2008 05:47 PM

extra info
The same hardware setup worked with no issues under CentOS5. However OpenSUSE is unable to even see the drive. Does anyone know what is different between the two distros that would make this be an issue?

davidstvz 08-20-2008 06:07 PM

This is probably not helpful at all... but I have come into a couple of systems I did not set up recently. Both have scsi tape drives and I expected them to be called st0 (and nst0 for the auto rewind). Instead they are called sa0 and rst0. I found them by noticing that there were corresponding nsa0 and nrst0 commands. Probably not the problem here, but keep an eye out for that in the /dev/ directory just in case.

yankeeinga 08-21-2008 08:04 AM

I don't have any of those either.

I do have a scsi directory under /dev, the devices listed under there are:

sdh2-0c0i0l0 sdh2-3c0i0l0p2 sdh3-4c0i0l0p1
sdh3-4c0i0l0p3 sgh2-3c0i0l0 srh0-0c0i0l0
sdh2-3c0i0l0p1 sdh3-0c0i0l0 sdh3-4c0i0l0p2
sgh0-1c0i0l0 sgh3-4c0i0l0

But still, shouldn't /dev/st0 (or tape or nst0) appear automatically?


yankeeinga 08-21-2008 12:51 PM

I found a solution
Sort of.

The SCSI card I was using was a generic one. I replaced it with an LSI card and the OS detected it when I rebooted it.

Thanks for your advice.

All times are GMT -5. The time now is 06:27 AM.