-   Linux - Newbie (
-   -   OpenSUSE & WinXP - dual boot issues (

thecourtenayboy 09-16-2008 09:39 AM

OpenSUSE & WinXP - dual boot issues
I'm very new to Linux, and have never used the Terminal or anything like that...I'm not totally useless but bare with me!

Ok, I had WinXP pro setup on a SATA drive, a PATA drive used for file storage, and last week I added another SATA drive which I wanted to use for a Linux distro.

I started with Fedora 9, installed it via the Live CD (KDE) and all went well. On reboot GRUB loaded up and Windows appeared as Other, but both OS's loaded up fine.

After a bit of tinkering with Fedora I decided I wasn't totally happy with it, and as I had previous experience with SUSE (very little exp but some), I thought I'd give that a try instead.

I removed Fedora but then Windows wouldn't boot properly and there was a GRUB message appearing and I didn't quite know what was happening. I looked online and read some suggestions to fix the mbr in the recovery console with fixmbr. I did this, and then Windows XP booted fine.

I then used the install DVD for SUSE to delete the partitions created by Fedora and then had to create my own for SUSE manually to make sure it didn't mess up my Windows setup. When I say manually, I was still using the GUI!

Anyway, I didn't really know that much about Linux partitions, and SUSE recommended that I install a SWAP partition in addition to the root partition. I did that, gave SWAP 650mb+ and the rest of the drive was for the root, 140gb+ formatted to ext3.

Ok, all went well and I got into SUSE fine, staretd playing around with it and got firefox and VLC player working, etc. Was very happy with the setup, and then decided to reboot.

After the reboot, Win XP started to load and I couldn't get into OpenSUSE, even by changing the boot sequence.

After some online searching it was suggested that I boot off the SUSE DVD and attempt to install GRUB. I tried this but since then Ive had big I can't boot into anything! Windows attempts to load and it shows the Win XP logo for a second followed by a BSOD. I can't remember the message on the BSOD, will have to check.

As there were a few options available in the GRUB setup thing, I tried a few different things but still no joy. I also tried booting into the Win XP Recovery Console to fix the mbr but this didnt work either.

Before I make a total mess I want to seek some advice. I've looked around on the net and it seems that the advice suggested here might help me at least get Win XP up and running:

As long as I dont lose Win XP and all of my files on my C:\ then I'll be happy. It would be nice to not have to setup SUSE again, but that's not really an issue. Although saying that, eventually getting the OpenSUSE + Win XP dual boot is my final aim...surely it can't be that hard?

Unknown_User 09-16-2008 10:50 AM

You seem to understand the problem well - as long as you don't do anything too drastic your data is happily sitting on your drives it is just that GRUB isn't pointing you at the appropriate places unless something horrible has happened in the meantime.

Windows has a horrible habit of ignoring anything other than windows filesystems and will reinstall the MS bootloader without a care as to what else it will destroy. Personally I would steer away from trying to put the Windows bootloader back unless it is absolutely necessary - my experience it that sometimes it works and on other occasions is makes an unholy mess that takes some sorting out!

In particular you don't want Windows messing with the file allocation tables and associated stuff - this would be very bad.

Can you boot using a Linux live CD and get access to the /etc/grub.conf config that is on your primary HDD? Posting a copy would be really helpful.

thecourtenayboy 09-16-2008 02:12 PM

ok, now I'm scared!
Right, i've opened grub.conf with KWrite and here's the result:

setup --stage2=/boot/grub/stage2 (hd2,1) (hd2,1)
setup --stage2=/boot/grub/stage2 (hd0) (hd2,1)

I'm worried because when I try to access the C:\ via SUSE it shows as empty...I'm hoping that not all is lost, else I'm gonna be pretty screwed to say the least!

Why oh why did I start experimenting without creating a backup?!?!?!?!

Unknown_User 09-16-2008 04:03 PM

Panic not (but a backup is always a wonderful thing)
So far so good.

SuSE works in a slightly different way to most distro's and what you are seeing is ok.

Can you now post the contents of /boot/grub/menu.lst

This will hopefully reveal something odd or at least point to where the problem may lie.

yancek 09-16-2008 04:35 PM

With the Fedora install, you were using Grub to boot and when you removed the Fedora partition, you removed most of the bootloader. The mbr contains 512 bytes of the bootloader which in total is usually around 100KB. That's why it wouldn't boot.

You used your windows CD to run fixmbr which overwrote the mbr allowing you to boot windows. I am assuming from your post you are still able to boot xp but not Opensuse. You don't have an entry in the boot.ini file for Opensuse so it won't boot. I expect you did not install Grub to the mbr so you are still using the xp bootloader, correct?

How did you try to re-install Grub? What commands? Did you try using SuperGrubDisk? Use your Opensuse CD and in addition to posting the contents of menu.lst as suggested by unknown_user, run the command: fdisk -l as root (that's a lower case letter L). Post output.

When you try to access C: your windows partition, do you have it mounted?

thecourtenayboy 09-16-2008 05:58 PM

Sorry guys but although it seems as if I know roughly what's wrong, I have absolutely no idea about Linux, and trying to get the contents of menu.lst for example is tough work. I tried using Kwrite but it didn't work. I literally need to be spoon fed what to type in the terminal, as all I know is Windows/Dos commands I'm afraid.

Anyway, SUSE is on the HDD and it's working fine when I boot from the DVD. So for now, GRUB really isn't worth worrying about. What I really need to fix is the Win XP problem.

In SUSE I navigate to My Computer and it lists the 3 HDD's. The 1st in the list shows no device name, and the available space field is blank. It does show the max space and the filesystem.

If I navigate to the root folder I can also see a Windows folder, this shows 2 folders: C & D. When I click on C it just shows an empty folder.

Now as GRUB isnt configured properly the PC attempts to boot into Win XP each time, but since I tried installing GRUB to the MBR & disk via the Expert install options on the DVD, Windows no longer boots. It looks as if it's going to boot, and the Win XP logo pops up for a second, but then I get a Blue Screen of Death, simply stating that windows has encountered a problem and has been shut down. It suggests running CHKDSK /F, which I aven't done yet.

The same happens if I try and boot into Safe mode.

I was considering running an XP repair via the CD, or maybe try to rebuild the Boot Config to get XP running again, but I'm worried about losing XP entirely, so would appreciate some advice on what best to do first.

henry_shadowjet 09-16-2008 09:10 PM

If it boots Windows half way, it doesn't appear to be a boot configuration problem if you ask me. I'm not 100% though so I think members here may be able to confirm that for me.

To me,it seems like your Windows operating system is a little stuffed up. But I think I have an idea of what you should try first.

Try booting from a bootable CD, the one that usually has a menu that says "Boot from HDD" or something similar. I know EBCD has this option. Google around for the place to download.

Good luck! ^^

yancek 09-16-2008 10:35 PM

Use your Opensuse CD in Rescue or Safe Mode to get to a terminal (command prompt) and log in as root user. Probably won't need a password. Run fdisk -l command and post output. Without this information, anyone trying to help you with editing menu.lst is just guessing.

Not being able to see anything in your xp C or D directories is to be expected as you do not have them mounted.

The problem windows encountered is probably not recognizing information from another bootloader since you tried to install Grub to the mbr. Seems like something went wrong when you tried to install Grub to the mbr, incorrect command or...?

You can use the command below (as root) to delete the mbr.
dd if=/dev/zero of=/dev/hda bs=446 count=1

You should then be able to do fixmbr with your xp CD. You DO have the xp cd?

After fixing the xp so it can boot, if you would rather boot from xp, try the link below which explains how to do this:

thecourtenayboy 09-17-2008 05:02 AM

Thanks henry_shadowjet i'll try EBCD out as soon as I get home, really need to salvage some files before I go any further with this.

With regards to GRUB, I have only ever tried installing it via the GUI, as I dont know any Linux commands. I first booted th DVD and tried to install GRUb to the MBR but when I rebooted Win XP booted up. I ran the DVD again and then selected a few other options, one of which was to install GRUB to the C:\ (I think). So I think that's why Win XP won't boot properly anymore. It does start to boot, as I said I can see the Win Xp logo for a second before it blue screens and tells me there's a problem.

I suspect that installing GRUB to C:\ has done some damage. Maybe installing GRUB has damaged the filesystem?

yancek, I can view the contents of my D:\, and the C:\ appears to be there but it's empty from within SUSE.

I will run EBCD and hopefully back everything up, then I'll try the other suggestions...although how do I login as root user?

Also, surely it's not the MBR that's damaged if WinXP is attempting to boot?

By the way, thanks for your help so far guys, I'm really lost and ur quick responses are very reasuring.

Unknown_User 09-17-2008 06:10 AM

Some good advice here.

Another idea that may help;

Do you have another Windows machine and a USB hard drive caddy to hand?

You could remove the drive that contains XP, put it into USB caddy and connect it to another PC to see if Windows can mount and copy your files.

It is important that you don't put the drive into another PC using SATA or IDE connectors as the windows version that the PC boots to will alter the FAT without a doubt.

Finally, if EBCD can't help (it is excellent) then I have had great success with Helix 3 (just google it). It is a forensic toolkit that can retrieve data that is in an appalling mess!

Good luck.

yancek 09-17-2008 09:45 AM

I doubt that Grub gave you an option to install to C:\, Grub will give you hda, sda, hdb, sdb with partition numbers after them.

If you are getting a windows screen at start of boot, then obviously Grub is not installed.

Log on as root by entering Rescue Mode (if you have that option) or safe mode. Type 'root' at the prompt, hit enter and the prompt should change. I don't have an 11.0 but on the 10.3 there is an option for Rescue and that's how it works. Try to get the output of 'fdisk -l'. No one will be able to give you accurate information without the partition info from this command on how to restore Grub.

My understanding is that Easy BCD is for editing Vista bootloader!

You could try downloading SuperGrubDisk to repair windows or Linux bootloader.

SystemRescueCD is goot at saving data, small download.

bparkerson04 09-17-2008 01:50 PM

Guys, I don't mean to post off topic here but I have to ask. I am new to linux, and I thought I was a pretty advanced computer user because of what I know in Windows...but reading the posts here I feel stupid. I don't understand some of the things being said here. How can I become efficient like this with linux and windows if possible, and be able to speak this language and know what I am talking about. I have learned alot about Ubuntu over the past few days just playing with it, but nothing like this. I have never had to mess with MBR's when troubleshooting windows. In my experience when there was an MBR problem, we would just reimage the drive, or in another situation maybe run a system repair off of the xp cd. Could you guys reccomend any good books to read to know this super advanced stuff not only in linux, but also in Windows? (I would like to learn Windows as well because of work and personal curiosity. I hate feeling stupid when it comes to this stuff, but I don't know where to learn this stuff outside of doing it at work or school...and school has yet to teach me anything advanced like this. I apologize again for interrupting this thread.

Unknown_User 09-17-2008 02:23 PM

Don't apologise bparkerson04, enthusiasm to learn is more than half the battle!

There are books-a-plenty out there and it would take all night to debate which ones are best.

Whilst Linux, MacOS and Windows are different in many ways there are lots of similarities so any learning will be a bonus.

Any of the bible type Linux books are excellent but you can get lost quite quickly.

Personally, I have learnt so much by choosing threads in this and other forums that look interesting, watching the responses and comparing it to my own systems. The community often provides a whole host of ways to skin the same cat and there are some very, very clever people out there.

Keep plugging away - as things drop in to place it is so very rewarding.

thecourtenayboy 09-18-2008 03:45 AM

Hang in there bparkerson04! I don't have a clue about Linux either, I'm good with Windows & used to work in IT, but with Linux I'm just starting out. I've done a fair bit of research on this forum and via google searches whilst trying to fix my problem, hence how I know about the MBR and GRUB, etc.

Try these websites out if you wanna get up to speed with Linux. I only found them the other day, but they look pretty good for beginers:

Wish I was getting into Linux whilst I was still at school! Would have made life so much easier = )


Anyway, back to the problem.

Last night I used EBCD and managed to backup all of my essential files, so I'm a lot more relaxed now! Thanks again for suggesting that, shame I'd never heard of it before, great piece of software.

I tried using SystemRescue CD but that was too advanced for me, I struggled trying to mount drives and stuff. Eventually got a drive mounted but then couldnt see anything on the drive. What it did tell me though was that there was a problem...showed an Exclamation mark next to the drive in the filemanager thing.

It also showed that there was an NTFS partition taking up most of the drive, and a small part, around 700k, was unformatted but seperate. I think that this small part was created by SUSE when I tried to install GRUB to the HDD. On the drive properties it also recommended running Chkdisk to repair the fault, which I think would be a good idea...especially now that I've got a backup.

After I get XP working again tho I'm, still gonna need to setup a dual boot, I'll follow the advice I've recieved here tho this time and hopefully I'll have more luck.

Cheers guys.

thecourtenayboy 09-18-2008 03:33 PM

Ok, I've managed to run the fdisk -l command, here's the result:

Disk /dev/sda: 164.6 GB, 164696555520 bytes
255 heads, 63 sectors/track, 20023 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x43654364

Device Boot Start End Blocks Id System
/dev/sda1 * 1 20022 160826683+ 7 HPFS/NTFS

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x145eddaf

Device Boot Start End Blocks Id System
/dev/sdb1 1 81 650601 82 Linux swap / Solaris
/dev/sdb2 * 82 19457 155637720 83 Linux

Disk /dev/sdc: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x8b53e835

Device Boot Start End Blocks Id System
/dev/sdc1 1 24321 195358401 7 HPFS/NTFS

sda1 is the drive with the problem.

All times are GMT -5. The time now is 07:14 PM.