-   Linux - Newbie (
-   -   Opensuse 11.1 Compiz Fusion Error. (

harshavarma 02-06-2009 08:08 AM

Opensuse 11.1 Compiz Fusion Error.
Hello friends...

Im new to linux and just installed the latest version of Opensuse 11.1 in my system. Evrything went fine and the OS is great. I wanted to install the COMPIZ FUSION for enabling the CUBE GRAPHICS. But i came to know that it is preinstalled in the Opensuse.I Have a Nvidia 9500Gt card with 2.5 gb ram and a Amd athlon X2 3600+ config. I downloaded the latest Nvidia drivers for linux and tried to install them. But i got a error that some "gcc" is missing.

I understood that it is a package and selected the yaST2 App for installing the packages. The point is i dont have a Internet connection. So i cant use the "ONE CLICK INSTALL" Feature from opensuse website. A friend of mine suggested that there will be a no of packages in the installation DVD itself. So i tried it and cant figure out what to install.

I selected the KDE Environment during the SUSE install. So i selcted some packages randomly starting with gcc and some other things.After this the Nvidia drivers gave a new error saying that "/.../..../.../kernel/kernel.h is missing. Now i checked my Utilities section and found the "COMPIZ MANAGEMENT UTILITY" showing that DESKTOP CUBE is enabled but im not getting any. I also heard that XGL & AIGL are necessary. I have no idea what they are.

Plz guide me through the process of Compiz installation.

**** My friends system has a internet connection and i tried to connect it to my system.But Im unable to do so. Can anyone tell me how to Connect to internet in OPENSUSE 11.1?

Ip Address

These are the sonnection details of my friend sytem.

kentyler 02-06-2009 09:54 AM

It looks like you need the kernel headers or kernel source/src/devel package(s) installed.

The kernel.h file alone can be searched out in google with the terms "kernel.h suse package" and it should tell you what package you need, follow that rule for the next file that is missing and on and on till it compiles without error.

Agrouf 02-06-2009 11:12 AM

For kernel.h, you need the kernel-source package

All times are GMT -5. The time now is 10:36 PM.