LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Opening tar.bz2 and tar.gz (https://www.linuxquestions.org/questions/linux-newbie-8/opening-tar-bz2-and-tar-gz-640880/)

chango77745 05-08-2008 03:32 PM

Opening tar.bz2 and tar.gz
 
I am really new to linux. I am sorry, but I am really trying to learn...I have bought books research online, but it is just not working. I really need like a step by step help process on this.

First, I have just installed ubuntu 7.10 and it is working just fine. I ran into a problem....my wireless does not work on the computer. The driver is bcm43xx

I found various forums on this and it all requires a file I need to "unpack" it is a tar.gz file.....I have read several ways to do this, but I am just not following. Something about tar jxf dillo-0.8.5.tar.bz2
I go to the terminal and get these messages "cannot open: no such...." "tar: Error is not recoverable..." "Child return status..."

So I am not sure what I am doing wrong...I have tried other command and stuff....Just to let you guys know this is the exact command I am putting in tar -jxvf /media/sbd/bcm43xx-fwcutter-006.tar.bz2
I am not sure if I am supposed to put the full path or just the filename...I dunno

I was really attracted to linux by some of the interfaces, like beryl and learn how to modify it,...I really want to learn how to do all this stuff...please help

Nylex 05-08-2008 04:19 PM

Post the exact error messages. If you're getting "no such file or directory" errors, then check that you're either in the same directory as the file, or that you've specified the full path correctly. Also check the spelling.

chango77745 05-08-2008 04:30 PM

Ok, I have further information. The tar.bz2 files are on a flash drive. I am not pretty sure I have the path correct, but when I try to drag these files to the desktop...or any files for that matter I get this error "Error 'I/O error' while copying '/media/sbd/....9.tar.bz2w'"

So perhaps it is not extracting them because it cannot file the path in the flash drive. The flash appears on the desktop and can be viewed, but I guess the contents cannot be used, but only viewed?

Nylex 05-08-2008 04:36 PM

Don't know what's causing that error, but try copying using the command line. The command is cp.

chango77745 05-08-2008 04:40 PM

"cp: missing destination file operand after '/media/SBD/bcm43vv.tar.gz'
Try 'sp --help for more information."

Nylex 05-08-2008 04:42 PM

Obviously you need to use common sense - you need to tell it where to copy the file to. If you want to copy to the current directory, you either specify that using the full path, or the shorthand, which is a single '.', e.g.

cp /media/disk/foo.tar .

chango77745 05-08-2008 04:51 PM

Quote:

Originally Posted by Nylex (Post 3147372)
you either specify that using the full path, or the shorthand, which is a single '.', e.g.

cp /media/disk/foo.tar .


I am sorry....I am new to linux.
This is where I get confused....I want to copy this to the desktop....so I would use cp /media/disk/name.tar to /home/user/desktop???? and how to I do '.' can you give me some examples with the paths I just gave you?

Thanks

viron 05-08-2008 06:02 PM

'.' refers to the current working directory (whatever directory you happen to be in at the time). This is really isn't a complicated matter. Even if you're new.

cp /media/sbd/yourfile.tar.bz2 /home/user/Desktop

If you can't copy the file, there are two possible reasons

1) The file you're trying to copy simply isn't there.
2) You (as a user) don't have permission to read the file. You will need to use 'sudo cp /media/sbd/yourfile.tar.bz2 /home/user/Desktop'

Note: This is done in console. You also need to change 'user' to your actual username. A good way to see if the file is there to begin with is to 'ls /media/sbd'

vadkutya 05-09-2008 07:17 AM

hey chango77745,

1. please give the full error messages. the '...' are not helpful.
2. is the 'w' at the end in "Error 'I/O error' while copying '/media/sbd/....9.tar.bz2w'" a typo you made in the post or in the command line? the 'w' is not supposed to be there, since it's a tar.bz2
3. I/O error doesn't sound like wrong command more like
a) corrupt file
b) bug in ubuntu (google: Error 'I/O error' while copying)

can you connect the flash drive to another pc/os and copy the file?

good luck, vadkutya

chango77745 05-09-2008 12:54 PM

When I try copying it from the command promt I get this message "cp: reading '/media/SBD/bcm43xx.tar.gz': Input/output error"

chango77745 05-09-2008 01:34 PM

I read on some forums that if I blacklist teh bcm43xx driver the utility will work. When I go to /etc/modprobe.d/blacklist and add the driver to the blacklist it will not let me save. It gives me the following error "Error writing /etc/modprobe.d/blacklist: No such file or directoy" I know that there is a file or directory because it takes me there when I type in the command....

It seems like there is error after error....can someone help me please!

fbianconi 05-09-2008 08:25 PM

/ect doesn't exist it should be /etc.
if you blacklist the driver it won't be there. Are you trying to use ndiswrapper or an alternative driver for it?
by the way, could you extract the (g/b)zipped tar file?
it's "tar -xzf file.tar.gz" for gzip, and "tar -xjf file.tar.bz2" for bzip2
if you need information on how to use any command try man pages 'man tar' for example or look for it on the help browser normally under man pages section.

chango77745 05-09-2008 08:49 PM

I am sorry, I meant etc....it was right in the code...it still says no such file or directory

Did I install it incorrectly or something???

Nylex 05-10-2008 12:53 AM

What exactly are you doing to add the driver to the blacklist file?

chango77745 05-10-2008 02:18 AM

Open a Terminal window
I Type "sudo nano /etc/modprobe.d/blacklist"
At the bottom I add the line
blacklist bcm43xx

then I type ctrl x to exit
then I confirm the file name
then I hit enter to save and I get the error message of no file or directory

I am trying to replace this driver with ndiswrapper

I think that this will make my wireless device work.


All times are GMT -5. The time now is 03:25 PM.