LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-12-2003, 03:03 AM   #1
StickDeath
LQ Newbie
 
Registered: Jun 2003
Posts: 3

Rep: Reputation: 0
OpenGL, Redhat 9.0, Enemy Territory


Hey im a linux newbie.... sorry to say

im trying that new wolfistien (spelling) and i keep gettign an error message.

i have a Athlon XP 1600+
256 ddr
Redhat 9.0
Geforce 2 mx - latest linux drivers

and i get this error:

[iceman@localhost iceman]$ et
ET 2.55 linux-i386 May 27 2003
----- FS_Startup -----
Current search path:
/home/iceman/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (4 files)
/usr/local/games/enemy-territory/etmain

----------------------
3729 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Couldn't get a visual
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

[iceman@localhost iceman]$




can anyone help me fix this??
 
Old 06-12-2003, 07:58 AM   #2
chakkerz
Member
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: RedHat (RHEL, FC, CentOS), openSuSE, Mac OS X
Posts: 653

Rep: Reputation: 32
check you are running the nvidia drivers: (as root)
bash-2.05b# lsmod | grep nvidia
nvidia 1539776 10 (autoclean)

if you get a line that mentions nvidia, you're sweet, if you don't
modprobe nvidia

make sure XFree86 uses the nvidia driver (instead of nv)
bash-2.05b$ cat /etc/X11/XF86Config | grep nv
Driver "nvidia"
NOT this:
bash-2.05b$ cat /etc/X11/XF86Config | grep nv
Driver "nv"

and also that you're loading glx
bash-2.05b$ cat /etc/X11/XF86Config | grep glx
Load "glx"
NOT
#Load "glx'
 
Old 06-14-2003, 09:58 PM   #3
StickDeath
LQ Newbie
 
Registered: Jun 2003
Posts: 3

Original Poster
Rep: Reputation: 0
i couldn't understand that
bash-2.05b# lsmod | grep nvidia

but i check the X11Config and changed "nv" to "nvidia" and it has "load glx" not "#load glx"

but it still comes with same error

wat now?
 
Old 06-14-2003, 11:35 PM   #4
chakkerz
Member
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: RedHat (RHEL, FC, CentOS), openSuSE, Mac OS X
Posts: 653

Rep: Reputation: 32
ok, if you are root running
lsmod | grep nvidia
will grep (grab) the occurance of nvidia in the output of lsmod. lsmod, on the otherhand lists (ls) the modules (mod) currently loaded.

so in otherwords,
lsmod | grep nvidia
checks what modules are running, and outputs all lines that contain "nvidia"

if you'd like it more explicit:
lsmod | grep nvidias && echo You\'re fine || echo You\'re screwed

will tell you if you're right or not. (you need to be root to run it correctly.
 
Old 06-15-2003, 01:04 AM   #5
StickDeath
LQ Newbie
 
Registered: Jun 2003
Posts: 3

Original Poster
Rep: Reputation: 0
yep done all that and it all comes up how u said it should but i still get the same message

what should i try now?
 
Old 06-15-2003, 04:49 PM   #6
chakkerz
Member
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: RedHat (RHEL, FC, CentOS), openSuSE, Mac OS X
Posts: 653

Rep: Reputation: 32
Sorry, my bad, should have been
lsmod | grep nvidia && echo you're fine && echo you're screwed

So if that's fine, then ... i dunno. Sorry. I got a similar error with Quake2 back in the day, and it was cause i didn't have the drivers right ... i did it three times until i got it working and in the end i had not followed the supplied instructions right.

Sorry i couldn't help ... but a friend of mine has enemy territory do i'll take a look at that if i get a chance.
 
Old 07-20-2003, 12:56 AM   #7
Plankton
LQ Newbie
 
Registered: Jul 2003
Location: California
Distribution: Red Hat 9.0
Posts: 1

Rep: Reputation: 0
StickDeath, I had the same error as you, also with RedHat 9.0. I had to install the Nvidia Linux drivers exactly as shown below to get Enemy Territory to work. Hope this works for you.

*** How to install the NVIDIA Linux IA32 driver
in Red Hat 9.0 ***


1. Verify that you have the following Linux modules installed:

Module Min Ver. Determining the Version
Linux Kernel 2.2.12 # cat /proc/version
XFree86 4.0.1 # XFree86 -version
Kernel modutils 2.1.121 # insmod -V
binutils 2.9.5 # size --version
GNU make 3.77 # make --version
gcc 2.91.66 # gcc --version

If you don't have any of these components installed
then click on the Red Hat icon, point to System
Settings and then click on Add/Remove Applications
icon. This starts the Package Management utility.
You can also type in redhat-config-packages at the
command line to start this utility. You will be
asked for the root password to continue.

Select the all the options from the Development
Tools and the Kernel Development sections. Click
on Update and then follow the instructions to to
install these components.

2. Download the latest Linux IA32 driver (currently
NVIDIA-Linux-x86-1.0-4363.run) from www.nvidia.com.

3. With root or su rights, modify the /etc/inittab
file and change the line that says:

id:5:initdefault

and change it to:

id:3:initdefault

4. Exit the X server by rebooting and then login
as root.

5. Change to the directory where you downloaded
the NVIDIA-Linux-x86-1.0-4363.run file and run the
following command.

sh NVIDIA-Linux-x86-1.0-4363.run

Follow the instructions to install the driver. If
you have a new Linux kernal that NVIDIA's FTP site
doesn't have an interface for then the install
utility will compile one for you.

6. After installation you must modify the /etc/X11/
XF86Config file while logged in as root.

Look in the Device section and change the line
that says:

Driver "nv"

and change it to:

Driver "nvidia"

Look in the Module section and verify that you
have:

Load "glx"

You should remove the following lines (if they
exist):

Load "dri"
Load "GLcore"

Save and exit the XF86Config file.

7. Modify the /etc/security/console.perms file
and remove the line that starts with <dri>. This
is usually called:

<dri>=/dev/nvidia* /dev/3dfx*

Also remove the following line:

<xconsole> 0600 <dri> 0600 root

Save and exit the console.perms file.

8.Reset the permissions to the console.perms
file by typing in:

chmod 0666 /dev/nvidia*
chown root /dev/nvidia*

9. Reboot the PC and test the configuration by
starting the X Server (startx command) and running
an OpenGL application. If there are no problems
then modify the /etc/inittab file and change the
id:3:initdefault line back to id:5:initdefault.

You are now done. You will need to rerun the
Nvidia .run file everytime you update the kernel.
 
Old 07-23-2003, 07:10 PM   #8
guinness
LQ Newbie
 
Registered: Jul 2003
Location: SF
Distribution: 7.3; w2k;XP
Posts: 18

Rep: Reputation: 0
just update properly you /etc/X11/XF86config-4 file coresponding to NVIDIA README, i had same problem now is fine
 
Old 07-25-2003, 03:01 AM   #9
newbe45
Member
 
Registered: Jul 2003
Distribution: fedora, gentoo
Posts: 128

Rep: Reputation: 15
I downloaded the NVIDIA drive and installed it i changed the XF86gonfig file to DRIVER "NVIDIA" now when i try to run the x server i recieve a critical error and that the driver NVIDIA can not be found. What do I do now?????
 
Old 07-25-2003, 03:32 AM   #10
newbe45
Member
 
Registered: Jul 2003
Distribution: fedora, gentoo
Posts: 128

Rep: Reputation: 15
fixed my first problem. I succesfully installed the nvidia driver. the game still will not work. this is what i get when i try to run the game.

----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Error couldn't open the X display
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Error couldn't open the X display
...WARNING: could not set the given mode (3)
Received signal 11, exiting...
 
Old 07-25-2003, 06:19 PM   #11
guinness
LQ Newbie
 
Registered: Jul 2003
Location: SF
Distribution: 7.3; w2k;XP
Posts: 18

Rep: Reputation: 0
Smile

OK i fixed my driver issue and i can start game:

you have to update your etc/X11/XF86config-4 file in text mode, logout from X.

and you have to see nvidia logo when you start your X, no logo driver is no good

let me know what happened

guinness
 
Old 07-26-2003, 08:51 PM   #12
newbe45
Member
 
Registered: Jul 2003
Distribution: fedora, gentoo
Posts: 128

Rep: Reputation: 15
I get NVIDIA logo when i start X
 
Old 07-27-2003, 01:27 AM   #13
guinness
LQ Newbie
 
Registered: Jul 2003
Location: SF
Distribution: 7.3; w2k;XP
Posts: 18

Rep: Reputation: 0
are you starting game from X or text mode?
 
Old 07-27-2003, 02:20 AM   #14
newbe45
Member
 
Registered: Jul 2003
Distribution: fedora, gentoo
Posts: 128

Rep: Reputation: 15
from x
 
Old 07-27-2003, 03:27 AM   #15
guinness
LQ Newbie
 
Registered: Jul 2003
Location: SF
Distribution: 7.3; w2k;XP
Posts: 18

Rep: Reputation: 0
hmmm i dunno, its gotta be something with driver, u aure you have right one.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Enemy Territory tykkea811 Slackware 2 12-12-2004 07:31 PM
Enemy Territory the_sLiDe Linux - Games 3 10-02-2004 06:50 PM
Enemy territory - DirectX? OpenGL? michaeltweak Linux - General 1 01-12-2004 09:46 AM
Enemy Territory Help coolmatty1000 Linux - Newbie 3 10-07-2003 02:17 PM
enemy territory? oubipaws Linux - Software 1 07-16-2003 02:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration