LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-24-2017, 11:55 AM   #1
atjurhs
Member
 
Registered: Aug 2012
Posts: 220

Rep: Reputation: Disabled
open home instead of Desktop when I log in?


instead of Desktop is there a way to set home as my default directory whenever i open a terminal? Just my own user preference

Thanks,

Todd
 
Old 01-24-2017, 12:10 PM   #2
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134
It probably already is. How are you opening the terminal?
 
Old 01-24-2017, 12:21 PM   #3
atjurhs
Member
 
Registered: Aug 2012
Posts: 220

Original Poster
Rep: Reputation: Disabled
mouse right click on the screen, choose "Open Terminal" from the gui
 
Old 01-24-2017, 12:28 PM   #4
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134Reputation: 2134
On most systems that option is labeled "Open Terminal Here". It's going to the Desktop because that's where you right clicked. If you had a file browser open in another directory, right clicked, and picked that option it would likely open it in that directory instead. Opening the terminal through the applications menu or with a keyboard shortcut should open it up in your home directory.
 
Old 01-24-2017, 12:41 PM   #5
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Todd:

Back in the day, gnome-terminal had just such an option.
Code:
gnome-terminal --working-directory=my/path/
So what terminal are we talking about please, or the OS version/"name"?
Please try to be specific.
Thanks.
 
Old 01-24-2017, 12:52 PM   #6
atjurhs
Member
 
Registered: Aug 2012
Posts: 220

Original Poster
Rep: Reputation: Disabled
suicidaleggroll - the "Open Terminal Here" option does not show up on the gui when I right click, only "Open in Terminal"

Habitual - I am running (it's my work machine so I am not able to change)

GNOME 2.28.2
Release 6.8
Kernel Linux 2.6.32-573.22.1.el6.x86_64

hopefully that's enough info on the system?

it seems to me that I should be able to put some sort of command in my .bashrc file to open the terminal in my home directory, but idk
 
Old 01-24-2017, 01:46 PM   #7
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.1 MATE
Posts: 8,016
Blog Entries: 5

Rep: Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861
Quote:
Originally Posted by atjurhs View Post
suicidaleggroll - the "Open Terminal Here" option does not show up on the gui when I right click, only "Open in Terminal"

Habitual - I am running (it's my work machine so I am not able to change)

GNOME 2.28.2
Release 6.8
Kernel Linux 2.6.32-573.22.1.el6.x86_64

hopefully that's enough info on the system?

it seems to me that I should be able to put some sort of command in my .bashrc file to open the terminal in my home directory, but idk
suicidaleggroll is correct. The reason that it is opening up the terminal in your Desktop directory is because you are launching the terminal by right-clicking on the desktop (the same would apply for another directory where you right-clicked within that directory, Desktop is no different).

Depending on your distribution, you should have a terminal icon somewhere on your system panel - click on that instead to open the terminal. You should find that it opens in your home folder e.g. /home/atjurhs.
 
Old 01-24-2017, 02:01 PM   #8
atjurhs
Member
 
Registered: Aug 2012
Posts: 220

Original Poster
Rep: Reputation: Disabled
that worked

I do have a "atjurhs Home" icon/link/shortcut on my desktop and right clicking on that does give me a terminal at my /home/atjurhs

I also put a "Terminal" icon/link/shortcut copied from the "Aplications/System Tools/Terminal" drop down and double clicking on that also gives me a terminal at the /home/atjurhs level.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why ./home/Desktop is incorrect and ./Desktop is correct? Yogesh24 Linux - Newbie 6 05-16-2015 01:42 PM
Desktop showing the contents of home folder on desktop in fedora 8 khalchian Linux - Newbie 2 08-18-2009 08:45 AM
Can't open /var/log/clamav/freshclam.log in append mode i_nomad Linux - Software 2 07-14-2009 05:06 AM
create a shortcut in /home/username/Desktop but not still not appear on desktop! swgiant Linux - Newbie 1 09-27-2008 11:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration