LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Only root can see second hard drive... (https://www.linuxquestions.org/questions/linux-newbie-8/only-root-can-see-second-hard-drive-173168/)

longhairhippy 04-22-2004 01:13 AM

Only root can see second hard drive...
 
Hello!
I've just dove into the Linux world and I have to say I'm VERY happy to do so...But, College linux is way different that windersME. My problems are these:

1. Only root can see my 2nd hard disk. My user account says access denied. I've tried using the user manager to add me to the 'disk' and even the 'root' group...but to no avail. I'm guessing I don't want to be logged into root all the time...

2. How do I change the screen resolution here?

3. Hmmm....tux racer? Hopefully someone can tell me how to get it! I gotta waste some time to get over this headache:)

Again from Newbieland!
Brent Pedersen

Oh yea...KDE3.1 College linux 2.5 (slackware based...I think)

320mb 04-22-2004 01:27 AM

post your /etc/fstab

you need to add a few things so users and see/mount/access that
2nd drive....................

screen res........
you need to edit your /etc/X11/XF86Config file..............

dimi 04-22-2004 01:30 AM

Well where is your 2 hd is mounted? and what file system is it? if u want to write to this hd, u need to change the file permission on the mount point. I'm assuming u know how to use "chmod" comnnad.

I'm not that familiar with KDE3.1, and not sure if there is resolution change app in KDE, but if you do reconfigure the X and configure for the res u want. I think its Xconfigurator to configure the X.

U should be able to download tux racer from http://tuxracer.sourceforge.net/download.html.

Good luck
D

Kristijan 04-22-2004 01:36 AM

If your mounting your second hard drive manually, as root, mount your second drive with a umask of 022. This will allow you to view your second hard drive, but will not allow you to write to it.

eg: ' mount -o umask=022 /dev/2ndhdd /mnt/mntpoint '

If possible, post your /etc/fstab

Good Luck, and also read the umask, mount and fstab man pages.

Kristijan

longhairhippy 04-22-2004 02:51 AM

The second hard disk is a 160g windowsME drive partitioned to a primary C: and 2 logical drives (on secondary partion) at D: and E:. To install Linux, I made a CL2.5 CD, and installed it on a 8.4gig HD as 'hda' and made my 136gig 'hdb'. This way, from the bios, I can simply turn off the 8.4 and I've got my windows 136 booting. I kinda figured I wouldn't be able to understand the dual boot thing right off hand...I was right:)

But I'm gunna get this stuff quick...Heres my fstab from linux:

none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
none /dev/pts devpts defaults 0 0
/dev/hda1 / ext3 defaults 1 1
/dev/hda2 swap swap defaults 0 0
/dev/hdd
/mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,user 0 0

/dev/hda1 /mnt/hda1 auto defaults 0 0

/dev/hdb1 /mnt/hdb1 auto defaults 0 0

/dev/hdb5 /mnt/hdb5 auto defaults 0 0

/dev/hdb6 /mnt/hdb6 auto defaults 0 0
none /proc/bus/usb usbdevfs defaults 0 0

/dev/hdd /mnt/cdrw0 iso9660 defaults 0 0

/dev/hdc /mnt/dvdr0 iso9660 defaults 0 0

longhairhippy 04-22-2004 07:54 PM

Allright...I'm starting to get this. After trying some things and seriously messing everything up I had more than a dozen devices in my devices window. Some editing of fstab has taken care of this and I have to say it's not so hard when you make it all nice and pretty. At the end, it remounted hda1 automatically, and this gives me 2 hda's in my devices window. Can I get rid of one? (safely?)

Here is my new fstab:

none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
none /dev/pts devpts defaults 0 0
none /proc/bus/usb usbdevfs defaults 0 0
/dev/hda1 / ext3 defaults 1 1
/dev/hda2 swap swap defaults 0 0
/dev/hdb1 /mnt/hdb1 auto defaults 0 0
/dev/hdb5 /mnt/hdb5 auto defaults 0 0
/dev/hdb6 /mnt/hdb6 auto defaults 0 0
/dev/hdc /mnt/dvdr0 iso9660 defaults 0 0
/dev/hdd /mnt/cdrw0 iso9660 defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,user 0 0
# /dev/hdd /mnt/cdrom iso9660 noauto,user,ro 0 0
# /dev/hda1 /mnt/hda1 auto defaults 0 0
# /dev/hda1 //hda1 auto defaults 0 0
# /dev/hdb1 //hdb1 auto defaults 0 0
# /dev/hdb5 //hdb5 auto defaults 0 0
# /dev/hdb6 //hdb6 auto defaults 0 0
/dev/hda1 /mnt/hda1 auto defaults 0 0


All times are GMT -5. The time now is 03:09 AM.