-   Linux - Newbie (
-   -   Ok What do the Pro linux guys think of my method ? (

zurkeyon 04-06-2008 05:35 PM

Ok What do the Pro linux guys think of my method ?
Thank you for all the help my other issues. I had toasted the driver install for Nvidia and could not get x to work, because none of the devel environments or kernel-devel were installed. I have started to use the package manager to insure that all available libs and devel/compilers, are installed prior to trying to install anything else.

Is that a good method ?

I am trying to finetune my install for mandriva as a multi-function fileserver. I am just getting started again with linux, after getting frustrated years ago when it was still 90% command line.

I will list my whole cheat sheet, and if any of you have the time, maybe you could apply pointers and additional steps to get right the hacks and workaround methods I am likely using.

Yes, I know I am ther King of run-on sentences :-)

ok...Here it is...

IBM eServer x225, dual 1.8 Xeon, 1280 ram, geforce4 mx440 PCI, 1.1 Terabyte SATA RAID (Striped 320g drives, and a solo 120g for OS), x2 Intel Extreme Gigabit Ethernet NIC, USING REMOTE DESKTOP and WEBMIN to ADMIN REMOTELY.

My Setup in detail (Kind of)...

MAKE Mandriva Install CD 2008 (or current)

Boot to CD

Perform Live Install and allow reboot. Removing the CD when Prompted.

Set IP and get internet up using the Mandriva System Config tool or using command line to set up eth0 and eth1

Install all possible devel, communication, compilers etc ( Several gig total )

Perform update several times until all possible packages are installed.

-------console stuff.....-------

shorewall clear - clears out firewall and opens all ports for server

Disable Shorewall by editing shorewall.conf and setting "Startup = no"

urpmi samba - installs samba

urpmi kernel-devel - installs kernel development package to allow nvidia driver install.


sh the nvidia driver and install it. driver install still partially fails but allows continued use of X


Drakconfig to re-setup screens


setup samba and shares for windows workgroup (Methods can be found online - I am using webmin to get it working for ease of use and remote admin of the system later on)


insure samba services start with - chkconfig smb on


Update system using Mandriva config tool to properly install drivers as most installs fail this tool corrects them and makes work the drivers. ( I think LoL :-P )


Attempt VNC setup. Using software manager – uninstall current VNC and reinstall tightvnc for use and configure. Possible that all will need to be pulled and reinstalled. (Tightvnc still not working correctly)

x11vnc from a terminal works best (so far)

Command = x11vnc –passwd (Password)

Still need this to open and run in a command line on startup

Investigate Webmin as a remote solution....

I have Mandriva 2006, I can access webmin locally using https://localhost:10000 and even by https://server01:10000. However, if I try connecting from any other computer I get "The operation timed out when attempting to contact server01". I can get to http://server01 and https://server01 remotely just fine. I liked at webmin settings, it is set to allow all IPs, I do have shorewall, so I checked it, and it had 80, and a few other ports that it accepted, but it did not have 10000 so I added 10000 to the list but I still get the same error when accessing webmin remotely. What could possibly be stopping it? Can someone help me figure this out?


The most secure way is using
ssh -L 10001:localhost:10000 youruserhere@server01

this will open an ssh connection to server01 using username yourusername.
after you logged in, your local port 10001 is forwared through the ssh connection to server01 (localhost on the other end...) port 10000.

now you can open your browser and type https://localhost:10001
for server01 this will look like you connect from localhost to port 10000.

Set up IP vs servername for use remotely. Works fine… Change IP for new environment

setup virtualbox and other tools as needed....

Still to do - - -

Set up ssh tunnel and dyndns for xvnc and make startup of xvnc server

Get Shares Completed

Get virtualbox to work

Anti virus ?

Anything you guys would do differently or any pointers you feel like offering ?

farslayer 04-07-2008 02:34 PM


Are you working on a Linux machine or a Windows PC ?

You need to look into how to restart services manually when necessary.
You should only have to restart your Linux PC when you update the kernel.

Other then that I don't use Mandriva, so I'll not comment on the other steps taken..


Webmin has a setting that is a security access restriction. By default it's set to allow local access only. You probably just need to go into webmin and allow access from other addresses.

Webmin -> Webmin configuration -> IP Access control -> ____________________

zurkeyon 04-08-2008 02:36 PM

I have found that after making some changes things still do not want to talk through my router afterwards without a reboot.

This is why I add the reboots.

I have actually gotten the proccess a bit more refined now but I still have several questions.

1. What command can be used in the Webmin command line module to start x11vnc? As far as I know a command exists to do this, but I am unaware of what it might be.

2. How do you use the free dyndns to get a server to be able to be hit with x11vnc from the web ?

Thats all for the moment :-)

Thanks again Linux Guys !!

All times are GMT -5. The time now is 08:38 PM.