LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   oh no, i forgot my root password (https://www.linuxquestions.org/questions/linux-newbie-8/oh-no-i-forgot-my-root-password-15613/)

deadman-inc-au 03-05-2002 07:24 AM

oh no, i forgot my root password
 
help, i forgot my root password, is there a way of changing it so i can use linux again

i dont want to have to re-install, as everything else is working fine this time around

btw i'm using mandrake 8.1, and i dont have a floppy drive :D

Mik 03-05-2002 07:38 AM

Try getting linux into single mode. Or pass init=/bin/bash when booting with lilo. Then use passwd to change the password. If that doesn't work then try with a boot disk. Mount the partitions in /mnt and then run:
chroot /mnt /usr/bin/passwd

acid_kewpie 03-05-2002 07:38 AM

when lilo loads, do a ctrl x and just run "linux single" or "linux init 1" this should boot linux into single user mode. i.e. root without entering a password. then just run "passwd" to set it again.

deadman-inc-au 03-05-2002 07:49 AM

i'm just about to try to get into single usermode again
last time when i type Linux-Mandrake single
it didn't work

btw the boot images for lilo that i have is Linux-Mandrake and Windows-200Pro

so i dont need to have a -single or -init 1 etc
anyway brb

progster 03-05-2002 08:00 AM

You could try getting the pass file as normal user and brute force it... should not be your first choice though! Brute forcing takes very long...

-Progster

deadman-inc-au 03-05-2002 08:04 AM

just tried the init 1 option,
and it didn't work still booted x auto
about to try the /bin/bash
option
brb:smash:

deadman-inc-au 03-05-2002 08:26 AM

ok that almost worked
when i did the init=/bin/bash option i got to the console in i presume single user

but got an error when i tried to passwd root

something about pwdb being locked by another resource

would i need to remount the root filesystem in rw mode,

and if so how do i do that?

Mik 03-05-2002 08:38 AM

mount -o rw,remount /

deadman-inc-au 03-05-2002 08:48 AM

you bloody beauty,
it worked,
you guys and gals are legends
thankgod i didn't have to reinstall:D:D:D:D:D


All times are GMT -5. The time now is 06:17 PM.