LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-10-2004, 06:33 AM   #1
pauloref
Member
 
Registered: Sep 2004
Location: Italy, between milano and varese
Distribution: gentoo from stage3 with 2.6.7 development kernel
Posts: 55

Rep: Reputation: 15
nvidia-kernel


I have recently instaled gentoo
I have a problem in emerging nvidia kernel, this is the error I get when I run:
emerge nvidia-kernel

*
* Could not determine your kernel version.
* Make sure that you have /usr/src/linux symlink.
* And that said kernel has been configured.
* You can also simply run the following command
* in the kernel referenced by /usr/src/linux:
* make include/linux/version.h
*

!!! ERROR: media-video/nvidia-kernel-1.0.6111-r2 failed.
!!! Function check_KV, Line 253, Exitcode 0
!!! (no error message)


What must I do. I have tried to run make include/linux/version.h
But nothing changes. I have a development kernel 2.6.7. HELP
 
Old 10-10-2004, 07:08 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Check and see if /usr/src/linux is a symlink to your actual kernel source tree
if it exists, do "make cloneconfig && make prepare-all" in there
 
Old 10-10-2004, 07:21 AM   #3
pauloref
Member
 
Registered: Sep 2004
Location: Italy, between milano and varese
Distribution: gentoo from stage3 with 2.6.7 development kernel
Posts: 55

Original Poster
Rep: Reputation: 15
i did "ls -l /usr/src/linux-2.6.7 and there is the correct symlink. But when i tried
"make cloneconfig && make prepare-all" in the directory /usr/src/linux-2.6.7 this was the result:

make[1]: *** No rule to make target `cloneconfig'. Stop.
make: *** [cloneconfig] Error 2


what else do you sudgest?

i still NEED HELP
 
Old 10-10-2004, 07:49 AM   #4
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try

ln -s /usr/src/linux-2.6.7 /usr/src/linux

if you've already configured and compiled the kernel in there you shouldn't need to do this:
make menuconfig (edit the config then save)
make prepare-all
 
Old 10-10-2004, 07:57 AM   #5
pauloref
Member
 
Registered: Sep 2004
Location: Italy, between milano and varese
Distribution: gentoo from stage3 with 2.6.7 development kernel
Posts: 55

Original Poster
Rep: Reputation: 15
when i try ln -s i have this error

ln: `/usr/src/linux': File exists

what hapends if i just go into /usr/src/linux-2.6.7 and do make parepare-all ??
 
Old 10-10-2004, 11:38 AM   #6
pauloref
Member
 
Registered: Sep 2004
Location: Italy, between milano and varese
Distribution: gentoo from stage3 with 2.6.7 development kernel
Posts: 55

Original Poster
Rep: Reputation: 15
where do you think the problem is?
 
Old 10-10-2004, 04:09 PM   #7
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
cd /usr/src/linux and then ls and post it so we can see what is in there.
 
Old 10-10-2004, 05:54 PM   #8
pauloref
Member
 
Registered: Sep 2004
Location: Italy, between milano and varese
Distribution: gentoo from stage3 with 2.6.7 development kernel
Posts: 55

Original Poster
Rep: Reputation: 15
here:

ls -l /usr/src/linux
lrwxrwxrwx 1 root root 21 Oct 11 00:13 /usr/src/linux -> linux-2.6.8-gentoo-r7
 
Old 10-10-2004, 05:58 PM   #9
pauloref
Member
 
Registered: Sep 2004
Location: Italy, between milano and varese
Distribution: gentoo from stage3 with 2.6.7 development kernel
Posts: 55

Original Poster
Rep: Reputation: 15
oh, i forgot to say, i have changed to a 2.6.8-dev kernel, under the sudgestion of someone else, and now my symlink is to a 2.6.8 kernel, however i stil have the 2.6.7 kernel in my /boot and his voice in /etc/lilo.conf
 
Old 10-10-2004, 06:47 PM   #10
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
What does uname -a say and what kernel is /usr/src/linux sounds like the kernel you are using and the one in linux are not the same.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
(EE) NVIDIA(0): Failed to initialize the NVIDIA Kernel module latino Linux - Hardware 5 06-03-2008 03:55 AM
(EE) NVIDIA(0): Failed to initialize the nvidia kernel module necbrownie Slackware 18 06-16-2006 02:20 AM
nvidia 6106, kernel 2.6.7, slackware 10, failure to load nvidia.ko Tarball_Phreak Linux - Hardware 3 08-04-2004 03:16 PM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 05:38 AM
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Stan the caddy Linux - Hardware 8 01-18-2004 04:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration