LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   nvidia is installed, how do i install openGl ? (https://www.linuxquestions.org/questions/linux-newbie-8/nvidia-is-installed-how-do-i-install-opengl-79153/)

qwijibow 08-05-2003 07:16 AM

nvidia is installed, how do i install openGl ?
 
the openGl games i am rying to install are complaining tat i do not have openGL installed.

i have installed my nVidia graphics card, i though this installed openGL too.

what do i have to do now ???

acid_kewpie 08-05-2003 07:18 AM

did you install the nvidia GLX rpm / tar.gz?

qwijibow 08-05-2003 07:24 AM

i did the whole change to runlevel 3, and run the binary provided by nvidia, then update my XF86Config to load the new driver.

when the X-server starts, the nvidia logo is displayed.

is, so i assumed i had completed the installation.

where can i find this GLX ?

ill just assume nvidia.com.

ill try that thanx for the quick reply.

acid_kewpie 08-05-2003 07:37 AM

yes there's two parts, NVIDIA_Kernel and NVIDIA_GLX

qwijibow 08-05-2003 07:46 AM

yes, i cant find a nvidia kernel for my system (redhat 9 i686)

non of them will install :(

and i cant find the damn page, im using the nvidia's home page search box, GRRR !

acid_kewpie 08-05-2003 07:51 AM

use the source luke!

qwijibow 08-05-2003 07:57 AM

lol,

yeah, thats always the answer.

i wouldnt mind using source if i werent so damn lazy and kept track of what i have and have not installed :)

rpm -q is a godsend :P

thanX (again)

the strange thing is, is that UT2003 runs fine on my system, and its an OpenGL game. ohh well.

thanx again for the help.

qwijibow 08-05-2003 08:15 AM

AGH !!!!!

cant even install from source !!!

:(

any surgestions ?

qwijibow 08-05-2003 08:19 AM

it looks like a programming error, but i know this cannot be the case

[root@localhost NVIDIA_kernel-1.0-1541]# make
rm -f nv.o os-interface.o os-registry.o Module-linux NVdriver
cc -c -Wall -Wno-unknown-pragmas -Wno-multichar -O -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -D_X86_=1 -Di386=1 -DUNIX -DLINUX -DNV4_HW -DNTRM -DRM20 -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=1541 -I. -I/lib/modules/2.4.20-8/build/include nv.c
In file included from nv-linux.h:56,
from nv.c:55:
/lib/modules/2.4.20-8/build/include/linux/malloc.h:4:2: #error linux/malloc.h is deprecated, use linux/slab.h instead.
nv.c: In function `nvos_get_kvirt_address':
nv.c:564: warning: implicit declaration of function `pte_offset'
nv.c:564: warning: assignment makes pointer from integer without a cast
nv.c: In function `nv_kern_mmap':
nv.c:1355: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
nv.c:1355: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
nv.c:1355: too few arguments to function `remap_page_range_R2baf18f2'
nv.c:1372: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
nv.c:1372: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
nv.c:1372: too few arguments to function `remap_page_range_R2baf18f2'
nv.c:1402: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
nv.c:1402: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
nv.c:1402: too few arguments to function `remap_page_range_R2baf18f2'
make: *** [nv.o] Error 1

acid_kewpie 08-05-2003 08:30 AM

in the Success Stories forum there is a thread bout how to install the drivers, try reading through that

qwijibow 08-05-2003 08:33 AM

where is this forum ?

RaWx 08-05-2003 09:18 AM

#error linux/malloc.h is deprecated, use linux/slab.h instead.

Try changing all occurences of the
#include <linux/malloc.h>
to
#inlcude <linux/slab.h> and then run the make process.

linux_pioneer 08-08-2003 08:47 PM

question: I have an Nvidia GForce2 and I'm running rh9. I install the nvidia driver everytime I do a kernel update. Is the opengl driver (two parts: NVIDIA_Kernel and NVIDIA_GLX) different from this? I know I have opengl because when I install from source ./configure sees opengl. Just curious.

Awatto 08-08-2003 11:53 PM

hmm, if i'm correct the 2 parts (NVIDIA_Kernel and NVIDIA_GLX) were what was used a while ago. Now they just have the .run file. I believe they are the same thing but the new way only has one file.

qwijibow 08-09-2003 04:03 AM

yeah, i used the new .run way.
i tried the old way because the new way didnt seem to work.

but it turned out my problem was a package i was trying to install gave VERY missleading dependancy information!!!!

when it said... Your system does not support openGL...
what it meant was, upgrade glut-devel


All times are GMT -5. The time now is 07:57 AM.