Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-12-2003, 09:46 AM   #1
LQ Newbie
Registered: Oct 2003
Location: Leiden, the Netherlands
Distribution: SuSE 8.2
Posts: 19

Rep: Reputation: 0
Question NVIDIA GeForce4 MX 440 / Suse 8.2 question

OK, I looked in all the forums, but alas.

Can anyone help me here?
I've got a NVIDIA GeForce4 MX 440 (SuSe 8.2 pro) and cannot get the HW acceleration to work. I've downloaded AND installed all the drivers form nvidia, but the problem seems to be in the card detection, even before I try to activate HW acceleration.

Looking on, I follow the instructions:
$ /sbin/lspci
gives <snip>
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)
So far, so good.
But then:
$ sax2 -p
xauth: (argv):1: bad display name "/unix:0" in "extract" command
xauth: (argv):1: bad display name "/unix:0" in "extract" command
Chip: 0 is -> NVidia 0x0181 01:00:0 0x10de 0x0181 AGP nv

--> I notice there's no slot description(!) like 1:0:0 or whatever.

which (0x0181) is the same as I see in Yast2 but NOT the same as with lspci! Changing de card definition with Yast2 to 'GeForce4 MX 440" (which IS listed) and subsequent testing the server crashes the system completely. I've also edited XF86Config manually (like it says in the NVIDIA readme), but alas!

Any help would be greatly appreciated!
Old 10-13-2003, 04:22 PM   #2
LQ Newbie
Registered: Oct 2003
Location: Leiden, the Netherlands
Distribution: SuSE 8.2
Posts: 19

Original Poster
Rep: Reputation: 0
Talking SOLVED!!!

I looked a little further on the internet and finally found a solution on the SuSE mailinglists!
A VERY nice genleman had suffered the same problem and tried to find a solution for nine days. He finally found that adding the option
Option "NvAGP" "0" to the XF86Config file

<like so>

Section "Device"
BoardName "GeForce4 MX 440"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Option "NvAGP" "0" <------------------------
Screen 0
VendorName "NVidia"

solved the problem. He still has trouble getting in the text consoles though (like, with ctrl-alt-F1), but that's not the case here. Everything _works fine. He has a different nVidia card, perhabs that explains it ???

The point is, he told me that he hasn't got a clue on *how* this works. It seems very counter-intuitive (like in quantum mechanics , switching *off* AGP, but well ...
See the whole solution on URL:

thanks, Jan!

WahWah (now going off for a trip to Saturn with Celestia)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
X doesn't start with Geforce4 MX 440 doubleD Linux - Newbie 3 05-29-2004 03:43 PM
Nvidia geForce4 MX 440 Crashes RH 8.0 jsexton Linux - Hardware 0 03-08-2004 12:45 PM
Debian bf2.4 and nVidia Geforce4 440 MX se question minze Linux - Newbie 1 08-31-2003 07:07 AM
GeForce4 MX 440 on RedHat 9 Ch1ngoken Linux - Distributions 6 07-20-2003 08:01 AM
GeForce4 MX 440 mlankford Linux - Hardware 1 09-20-2002 12:36 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:28 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration