-   Linux - Newbie (
-   -   Nvidia Fedora 1 problem (

Draylath 05-31-2004 10:12 AM

Nvidia Fedora 1 problem
Hi guys, I need help again,

After a day of having my new Fedora system up and running I decided I wanted to make the best out of my GeForce4 MX 420 so I got the driver at Nvidia's site and followed the instructions. It installed just fine and I edited the XF86Config File as instructed. I rebooted and did the startx thing and it gave me XIO error saying that the Nvidia module (or was it device) coulnt start.

I have done a bit of searchng on this forum but some of the replies looked a bit out my depth, can anyone give my some nice clear 3 words a page help

Thanks in advance,

b0uncer 05-31-2004 10:27 AM

can you post some lines from your /var/log/nvidia (not sure about the exact name, but nvidia-something..) and /var/log/XFree86.0.log ? in a terminal/console do this:

cat /var/log/XFree86.0.log | less

then scroll down to the end of the file and see the last lines, and copy as many of them as you can see containing errors, something weird or something that could be helpful and has something to do with your card's driver....then paste & post it here. do the same with your /var/log/nvidia-something logfile too..if you don't know the exact name either, do

cd /var/log
ls nv*

and you should get it's name. then we can start solving this one out :)

Draylath 05-31-2004 11:07 AM

Thanks for you're reply,

Ok this is for the second file output you asked for

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel source path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site :

Using: nvidia-installer ncurses user interface
-> License accepted.
-> A precompiled kernel interface for kernel 'Fedora core 1 kernel
2.4.22-1.2115.nptl Athlon' has been found here:
executing: 'cd ./usr/src/nv; /usr/bin/ld -d -r -o nvidia.o precompiled-nv-li
nux.o nv-kernel.o'...
-> Kernel module linked successfully.
-> Installing both new and classic TLS OpenGL libraries (but only new XFree86
TLS libraries.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-5336):
executing: './usr/src/nv/'...
executing: '/sbin/ldconfig'...
executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Sanity check passed.
-> Shared memory test passed.
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 1.0-5336) is now complete. Please update your XF86Config file as
appropriate; see the file /usr/share/doc/NVIDIA_GLX-1.0/README for details.

As for the first one I got no errors. I think this is because I changed everything back in the XF86Config file to how it was after I got problems and X all worked fine again (I was relived). Shall I put it back how it was when it went wrong?

Draylath 05-31-2004 01:40 PM


Should I try reinstaling the driver using the --kernel-name after getting it from uname -r?

b0uncer 05-31-2004 02:22 PM, I don't think that's necessary. the logfile didn't seem to tell about any errors, so as far as I understand, everything should be ok...

I suggest you read through the README file carefully again, make the changes to your XF86Config file, or XF86Config-4, depending on your can see this by giving a command like this:

cat /var/log/XFree86.0.log | head -20

that types the first 20 lines of the logfile...there should be somewhere around line number 16 a line starting with "(==) Using config file:" that tells your config file's name and location.

so edit the your XFree's config file..then try to restart X (you shouldn't need to reboot) completely. if it won't start, then check your /var/log/XFree86.0.log and you _should_ see some error/warning lines at the bottom..those lines should start with either (EE) meaning error or (WW) meaning warning, or both. copy at least those lines here...

I think one of the most important parts in the XF's config file's editing is that you check that you remove the certain lines that README tells you or more of them might be at the bottom of the file, and not in the screen section like the see through the whole config file.

I wish you luck, but if you don't succeed yet, post the end of the XFree86.0.log here and we'll see what's going on...

Draylath 05-31-2004 03:33 PM

Many thanks for your replies. Still no joy though. I don't seem to have an XF86Config-4 file in tthe relevent directory. I made sure that I was changing the right bits. I have printed out a copy of the Readme as I've never done this before, it wanted Load "dri" and Load "GLCore" removing and Load "glx" added. In respose to your last post I found some stuff that said

Section "DRI"
Group 0
Mode 0666

So I wiped that also and to no avail and I changed the "nv" to "nvidia"
When I put it all back to the way it was X starts just fine again so I hope that has not effected the following log you requested

(==) NV(0): Write-combining range (0xc8000000,0x4000000)
(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
8x8 mono pattern filled rectangles
Indirect CPU to Screen color expansion
Solid Lines
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(**) Option "dpms"
(**) NV(0): DPMS enabled
(==) RandR enabled
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXActiveScreens from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)
(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
(II) Keyboard "Keyboard0" handled by legacy driver
(**) Option "Protocol" "IMPS/2"
(**) DevInputMice: Protocol: "IMPS/2"
(**) Option "AlwaysCore"
(**) DevInputMice: always reports core events
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) DevInputMice: ZAxisMapping: buttons 4 and 5
(**) DevInputMice: Buttons: 5
(II) XINPUT: Adding extended input device "DevInputMice" (type: MOUSE)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) DevInputMice: ps2EnableDataReporting: succeeded
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5

Draylath 05-31-2004 06:06 PM


(Would I save myself a lot of time and effort by getting a new graphics card or is this fixable?)

Draylath 06-01-2004 03:59 AM


Draylath 06-01-2004 12:33 PM

Sorry to be rude and "bump again" but this is the last bastion of trouble in my machine and I wish to squash it :)

Draylath 06-01-2004 04:52 PM

I think I may have posted the wrong log. I've done a bit of digging and tried a few things but I still get this message (got from XF86Config.0.log file)

(**)NVIDIA(0): Depth 24 (--) framebuffer bpp 32
(==)NVIDIA(0): RGB weight 888
(==)NVIDIA(0): Default Visual is TrueColor
(==)NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--)NVIDIA(0): Linear framebuffer at 0xC8000000
(--)NVIDIA(0): MMIO registers at 0xCE000000
(EE)NVIDIA(0): Failed to initialise the NVIDIA graphics device
(EE)NVIDIA(0): ***Aborting***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found but non have a useable configuration.

Sorry if I was posting wrong logs earlier

Draylath 06-03-2004 09:15 AM

I still can't get this working. I've been doing digging on this forum and I've seen a bit on XF86Config-4. Should I use this file (I don't have it by default) as I have a 4.x (not sure which) of X server? Sorry to bang on about this but I really want to beat it! Thanks

All times are GMT -5. The time now is 11:40 PM.