-   Linux - Newbie (
-   -   nvidia Driver probs after upgrading card (

JShadow 01-20-2005 04:09 PM

nvidia Driver probs after upgrading card
I recently installed Fedora core 3.

I had a Geforce 2 MX, and got the latest nvidia driver to work fine after removing mesa.

I decided to upgrade my video card to get better FPS in counter-strike. I purchased a NVidia Geforce FX since I thought that would make the upgrade simple. Since the nvidia driver is supposed to be unified I figured I could just remove the old card and put the new one in and it would work. Things didn't turn out to be that simple.

X hangs at a black screen when I try startx. First I tried removing and then reinstalling the drivers, then I tried the various fixes listed in the forums here. No luck so far.

I tried the older driver, the old patched driver, downgrading the kernel to 2.6.9, uprading the kernel to 2.6.10, playing with the config files, and the bios settings and so far nothing really seems to effect it at all.

It seems to hang right after loading GLX.

The nv driver loads fine, so I know the card is ok.

Any help would be much appreciated.


# Xorg configuration created by system-config-display

Section "ServerLayout"

#        Identifier    "single head configuration"
        Identifier    "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath    "unix/:7100"

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
#        Load  "dri"

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#        Option        "Xleds"                "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#        Option        "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#        Option        "XkbModel"        "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#        Option        "XkbModel"        "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#        Option        "XkbLayout"        "de"
# or:
#        Option        "XkbLayout"        "de"
#        Option        "XkbVariant"        "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
#        Option        "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
#        Option        "XkbOptions"        "ctrl:nocaps"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option            "XkbModel" "pc105"
        Option            "XkbLayout" "us"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "IMPS/2"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5"
        Option            "Emulate3Buttons" "yes"

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "MAG 986PF"
        DisplaySize  370        270
        HorizSync    30.0 - 86.0
        VertRefresh  50.0 - 160.0
        Option            "dpms"

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "NVidia"
        BoardName  "NVIDIA GeForce FX (generic)"
        Option "DPMS"
        Option "IgnoreEDID" "1"
        Option "RenderAccel" "true"

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    16
                Modes    "800x600" "640x480"
        SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"


jschiwal 01-20-2005 04:31 PM

You will want to install the kernel source for your current kernel version, and then download the NVidia driver. Running it as root will compile a new 'nvidia' driver for your kernel version.

Sometimes something will happen on my desktop and x windows won't start. Rerunning the driver install program fixes the problem.

Good Luck!

JShadow 01-20-2005 04:35 PM

Yeah I already tried running the NVidia installer and extracting it and then doing make install.

jschiwal 01-22-2005 05:27 AM

The nvidia installer isn't a traditional tarball. You run the ./nvidia-installer script. You need the kernel-source installed first.

All times are GMT -5. The time now is 11:59 AM.