LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-01-2003, 04:48 PM   #1
rooman
Member
 
Registered: Mar 2002
Location: Lausanne, Switzerland
Distribution: Mandriva 2007.0
Posts: 228

Rep: Reputation: 30
nvidia driver = crash!!


mdk 9.1
I've installed the nvidia drivers with the easy to use new installation shell script and the one for all 6mb driver file, no errors.
With nv changed to nvidia in XF86Config-4, I get the same grey screen as the economy mode that cuts in when using the console. The PC needs a hardware reset and file system checking each time before working again!
Here are the only clues I could find in the x-server log.

(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4363
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX

(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not found)

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
Could this be driver/module related or APM (BIOS screen power?/v-synch?)
 
Old 07-01-2003, 04:57 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
does your motherboard have a kt400 chipset?
 
Old 07-01-2003, 05:00 PM   #3
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
oh and forgot to mention, that the warning has nothing to do with not getting this to work...
 
Old 07-01-2003, 06:30 PM   #4
ironz
Member
 
Registered: Jun 2003
Location: Montréal, Québec
Distribution: red hat 9
Posts: 84

Rep: Reputation: 15
maybe ur kernel is not compatible with the new nvidia drivers.

Me too i had this problem before but now it's okay.

Your kernel must be 2.4.20-8 and under. Upper this the nvidia launch an error.

i have reinstalled rehat linux 9 and the drivers and it's works great!!!

H4Ve PhuN
 
Old 07-01-2003, 06:32 PM   #5
ironz
Member
 
Registered: Jun 2003
Location: Montréal, Québec
Distribution: red hat 9
Posts: 84

Rep: Reputation: 15
i suggest (when u have just reinstalled linux) to don't patch the kernel and all others updates like that. Only if the kernel is very old and cause crash.

Last edited by ironz; 07-01-2003 at 06:33 PM.
 
Old 07-02-2003, 07:12 AM   #6
rooman
Member
 
Registered: Mar 2002
Location: Lausanne, Switzerland
Distribution: Mandriva 2007.0
Posts: 228

Original Poster
Rep: Reputation: 30
mobo= MSI 645 Ultra-C with SiS645 & SiS961/961B chipsets
kernel=2.4.21-0.13mdk
 
Old 07-02-2003, 03:48 PM   #7
rooman
Member
 
Registered: Mar 2002
Location: Lausanne, Switzerland
Distribution: Mandriva 2007.0
Posts: 228

Original Poster
Rep: Reputation: 30
I've done an lsmod and nvidia is not mentionned;
I've put alias char-major-195 nvidia in modules.conf as I saw suggested elsewhere;
I did a insmod nvidia and a warning message about a tainted kernel, what does that mean?
startx still gives the grey screen of a hardware crash...
log file mes.= (EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not found)
 
Old 07-02-2003, 04:06 PM   #8
solspin
Member
 
Registered: Apr 2003
Location: California, USA
Distribution: What works
Posts: 97

Rep: Reputation: 15
I would stick with combing through your XFree86 config file and make sure you updated it per Nvidia's instructions. I can't tell you how many times I have missed the small details. If the Nvidia installer successfully updated the driver, then the only other thing to change is the XFree86 config file. I am running kernel 2.4.21 and have installed and re-installed the Nvidia driver with no problems. Was there anything else you changed in the config file besides the Nvidia references? Maybe you could copy back your original XFree86 config file and start over. That is, if you made a backup!

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist.
 
Old 07-02-2003, 04:10 PM   #9
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
Quote:
og file mes.= (EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not foun
well as you see by this message, it can't load the nvidia driver...
by looking at your kernel version i don't think you updated your kernel cause i think that is the default one that comes with mdk, but if it isn't then specify the kernel your using with the install script...so the next thing is if it can't find the nvidia driver, maybe you should install it again....are you sure you didn't install the drivers in failsafe mode? if so that could be an issue....also make sure you have irq assigned to vga set to enabled in the bios and pnp os aware disabled....
 
Old 07-02-2003, 05:11 PM   #10
pyro
LQ Newbie
 
Registered: Feb 2002
Posts: 9

Rep: Reputation: 0
Hi,
maybe the option (in the driver section)
NVAGP = "0"
will fix your problem it fixed it with my tnt
 
Old 07-06-2003, 04:00 PM   #11
rooman
Member
 
Registered: Mar 2002
Location: Lausanne, Switzerland
Distribution: Mandriva 2007.0
Posts: 228

Original Poster
Rep: Reputation: 30
thanks for ideas chaps.
My AMI bios does not have the options quoted, all that I have is a set of irqs with the options of ISA or PCI/PnP.
I have the stock mdk 9.1 kernel delivered on the cd, no patches.
Clearly there's a prob with the glx extension not loading.
 
Old 07-06-2003, 09:04 PM   #12
RottenMutt
Member
 
Registered: Jul 2003
Location: dfw
Distribution: Latest Fedora Release
Posts: 195

Rep: Reputation: 31
check bus address:
lspci

then add this to your xf86config file under "section device" as shown in the nvidia example:

BusID "PCI:04:00:0"

where the 04:00:0 is your card address...

also make sure you booted to the kernel you run when you complied/installed you driver.
kernel version:
uname -r

to make a boot disk:
mkbootdisk --device /dev/fd0 2.2.16-22
insert your kernel version...

boot to disk and at boot prompt type "linux 3" this will boot to you kernel and the command prompt
 
Old 07-06-2003, 09:44 PM   #13
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Did you comment out the 'load "GLcore"' and 'load "dri"' lines in your /etc/X11/XF86Config-4 file?
 
Old 07-08-2003, 03:21 AM   #14
v00d00101
Member
 
Registered: Jun 2003
Location: UK
Distribution: Fedora 8, Centos 5.1
Posts: 480

Rep: Reputation: 30
i had a similar problem on mandrake with a nvidia gfx card and i never did fix it after 2 weeks of messing about.

I installed redhat9 on it and have not had any probs except when i update the kernel (need to rebuild the nvidia driver).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver in fedora 3 (FC3) crash xwindow fixed hououji2000 Linux - Newbie 1 09-05-2005 09:03 PM
nvidia driver makes xmms crash doralsoral Linux - Software 2 01-09-2005 09:32 AM
Nvidia driver causes crash on Mandrake 10.1 RedRedKrovy Linux - Newbie 3 01-02-2005 04:06 PM
crash when using nvidia driver (slackwarwe 10) eeyoree Slackware 12 10-14-2004 12:53 PM
mandrake 10...nvidia driver...kde crash tjb Mandriva 10 08-10-2004 03:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration