Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-17-2005, 01:12 AM   #1
Registered: Dec 2003
Location: Pacific Palisades
Distribution: Suse 9.0
Posts: 48

Rep: Reputation: 15
nvidia card not working suse 9.3 but did 9.2

I was running suse 9.2 with 3d acceleration working, however, when I upgraded my system to 9.3 (installed fresh) it no longer works. I installed the nvidia driver using yast with no problem. Here's my xorg.conf file:

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"

Section "ServerFlags"
Option "AllowMouseOpenFail"

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Logitech Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"

Section "Monitor"
HorizSync 31-48
Identifier "Monitor[0]"
ModelName "1024X768@60HZ"
Option "DPMS"
VendorName "--> VESA"
VertRefresh 50-60
UseModes "Modes[0]"

Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 62.35 1024 1056 1184 1312 768 772 776 792 -HSync -VSync

Section "Device"
BoardName "GeForce FX 5200 (0x0322)"
BusID "1:0:0"
Driver "nv"
Identifier "Device[0]"
VendorName "NVidia"

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768"
SubSection "Display"
Depth 16
Modes "1024x768"
SubSection "Display"
Depth 24
Modes "1024x768"
SubSection "Display"
Depth 32
Modes "1024x768"
SubSection "Display"
Depth 8
Modes "1024x768"
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Screen "Screen[0]"

Section "DRI"
Group "video"
Mode 0660

when I lsmod | grep glx I got nothing.

when I lsmod | grep agpgart I got:

agpgart 32296 1 intel_agp

when I try to reconfigure the monitor or enable 3d acceleration in yast, it says its not installed. However, when I goto online update and select installed and installable patches, it says its installed. Also, when I run glxgears, the fps is low at 200.

I'm lost, any help?
Old 05-17-2005, 01:25 AM   #2
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
The nv driver doesn't support 3D acceleration. You need to get the drivers from (they support 3D acceleration).
Old 05-17-2005, 05:01 AM   #3
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
If you already installed the nvidia driver, then you should change the line
Driver "nv"
Driver "nvidia"
Old 05-22-2005, 07:57 PM   #4
LQ Newbie
Registered: May 2005
Location: Adelaide, South Australia
Distribution: SuSE
Posts: 1

Rep: Reputation: 0
Same problem - fixed

Had the same problem, same Nvidia card.
I loaded the latest Nvidia driver (not the SuSE YAST version) and all is well.

NB: This is a later version the the YAST YOU version!
Old 05-22-2005, 10:51 PM   #5
Senior Member
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45
according to Nvidia's HOWTO

you should use YAST, but make sure you have all the preconfigs before installing.

also from Nvidia


In April of 2004, the Foundation released an X server based on
the XFree86 X server. Many Linux distributions will use the
X server in the future, rather than XFree86. The differences between
the two X servers should have no impact on NVIDIA Linux users with
two exceptions:

1) The configuration file name, though it uses the same syntax
as XFree86's XF86Config file, is called /etc/X11/xorg.conf;
this README refers generically to these configuration files as
"the X config file".

2) The log file, though its output is nearly identical
to the XFree86.0.log file, is called /var/log/Xorg.0.log; this
README refers generically to these files as "the X log file".

When XFree86 4.0 was released, it used a slightly different XF86Config
file syntax than the 3.x series did, and so to allow both 3.x and 4.x
versions of XFree86 to co-exist on the same system, it was decided that
XFree86 4.x was to use the configuration file "/etc/X11/XF86Config-4"
if it existed, and only if that file did not exist would the file
"/etc/X11/XF86Config" be used (actually, that is an over-simplification
of the search criteria; please see the XF86Config man page for a
complete description of the search path). Please make sure you know
what configuration file your X server is using. If you are in doubt,
look for a line beginning with "(==) Using config file:" in your X log
file ("/var/log/XFree86.0.log" or "/var/log/Xorg.0.log").

If you do not have a working X config file, there are several ways
to start: there is a sample config file that comes with XFree86,
and there is a sample config file included with the NVIDIA driver
package (it gets installed in /usr/share/doc/NVIDIA_GLX-1.0/).
You could also use a program like 'xf86config'; some distributions
provide their own tool for generating an X config file. For more
on X config file syntax, please refer to the man page (`man XF86Config`,
or `man xorg.conf`).

If you already have an X config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")


Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist. There are also numerous options that can be added to the
X config file to fine-tune the NVIDIA X driver. Please see Appendix D
for a complete list of these options.

Once you have configured your X config file, you are ready to restart X
and begin using the accelerated OpenGL libraries. After you restart X,
you should be able to run any OpenGL application and it will automatically
use the new NVIDIA libraries. If you encounter any problems, please
see the FREQUENTLY ASKED QUESTIONS section below.
that should help you figure out exactly what is going on.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.0 doesn't detect Ethernet card on nVidia shipset 2, on-board card Realtek 8201 devilpim Linux - Newbie 3 05-27-2006 01:08 AM
TV-out working with NVIDIA card and fedora core 2 Vie Linux - Hardware 6 09-12-2004 04:49 AM
Nvidia Card stopped working after update. DFarist Linux - Hardware 6 02-11-2004 06:52 PM
Getting old HP monitor working with new Nvidia Ghx card? mymojo Linux - Hardware 0 12-11-2003 03:05 PM
my nVidia Ethernet card not working voodooutt Linux - Newbie 16 11-17-2003 12:44 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:50 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration