-   Linux - Newbie (
-   -   Nvidia 8800 GTS Poor Desktop Performance (

Seibikitei 10-07-2007 11:22 AM

Nvidia 8800 GTS Poor Desktop Performance
Ok, I finally gave in... this is my first time posting a Linux question on a board. So far I've been able to troubleshoot everything I've run into with Google, etc. Anyways, here goes...

I'm running Kubuntu 7.04 with an Nvidia 8800 GTS graphics card, the issue is that performance in KDE is fairly poor on the desktop. Windows jerk and act like there isn't enough resources when minimizing and maximizing, Firefox and Konqueror tabs jerk and sputter when opening or changing tabs, and other assorted degraded UI performance. Granted the system is not unusable but its definitely not where it should be. I have Vista installed on this system as well (which won't boot after installing Kubuntu but that's a different issue) and when it was working, the desktop was smooth as glass even with Aero enabled.

The video driver installed is the nvidia-glx-new package version 100.14.19 and was installed using Envy along with a collection of other nvidia packages. This is the most recent driver from what I've been able to determine. As a sidenote I have installed World of Warcraft using Wine and it works spectacularly so I have no issue with 3D effects, its just this poor performance in KDE.

As resource, here's a copy of what xorg.conf looks like:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:29:35 PDT 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"

Section "Files"

        # path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

Section "Module"
    Load          "i2c"
    Load          "bitmap"
    Load          "ddc"
    Load          "extmod"
    Load          "freetype"
    Load          "glx"
    Load          "int10"
    Load          "vbe"

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "us"

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ImPS/2"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "true"

Section "InputDevice"
    Identifier    "stylus"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "stylus"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY

Section "InputDevice"
    Identifier    "eraser"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "eraser"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY

Section "InputDevice"
    Identifier    "cursor"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "cursor"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY

Section "Monitor"
    Identifier    "Generic Monitor"
    HorizSync      28.0 - 51.0
    VertRefresh    43.0 - 60.0
    Option        "DPMS"

Section "Device"
    Identifier    "nVidia Corporation G80 [GeForce 8800 GTS]"
    Driver        "nvidia"
    Option        "RenderAccel" "true"
    Option        "AllowGLXWithComposite" "true"

Section "Screen"
    Identifier    "Default Screen"
    Device        "nVidia Corporation G80 [GeForce 8800 GTS]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    Option        "AddARGBGLXVisuals" "True"
    Option        "DisableGLXRootClipping" "true"
    SubSection    "Display"
        Depth      1
        Modes      "1024x768" "800x600" "640x480"
    SubSection    "Display"
        Depth      4
        Modes      "1024x768" "800x600" "640x480"
    SubSection    "Display"
        Depth      8
        Modes      "1024x768" "800x600" "640x480"
    SubSection    "Display"
        Depth      15
        Modes      "1024x768" "800x600" "640x480"
    SubSection    "Display"
        Depth      16
        Modes      "1024x768" "800x600" "640x480"
    SubSection    "Display"
        Depth      24
        Modes      "1680x1050" "1024x768" "800x600" "640x480"

Section "Extensions"
    Option        "Composite" "Enable"

The only thing I can think to do now is start with a clean xorg.conf file using the xorg -config command then run the nvidia-xconfig command and hope it generates what I need. Envy automated a lot of tasks when it came to setting up the file and now after installing and uninstalling compiz-fusion I think there might be some useless junk in there. Anyways, this is the issue I've been having, I appreciate any insight you guys might have into the problem and just let me know if there's any more information that would be helpful.

Seibikitei 10-07-2007 07:12 PM


I went ahead and uninstalled the Nvidia driver using Envy, purged all the associated packages, and then reset my xorg.conf to use the genero driver. This worked and I'm right now at the desktop with the Vesa driver and it looks like my problem was the Nvidia driver itself or how it was configured. Using the Vesa driver all the little nags I described above have gone away. Windows minimize and maximize smoothly, changing tabs in Firefox is instantaneous as is opening and closing them.

Now for the bad news... earlier I tried the "packaged" Ubuntu driver in the repository (nvidia-glx-new) and could not get it to work, at least not out of the box and I haven't figured out how to get it going. Apparently its a common bug with the 8800 GTS that you get a black screen of death when X attempts to start. It sits there with one blinking cursor and will not start anything else. I had to open a terminal session, log in, and run dkpg-reconfigure xserver-xorg to set the Vesa driver back up.

Oh well, next step is to reinstall the official driver from the Nvidia site. If its bad form replying to your won post, I apologize. This may have been more appropriately done as an edit but it seemed like some people have been looking at my post and I figured why not keep people updated with my progress. Anyways, help and suggestions are always welcome.

Seibikitei 10-08-2007 01:23 AM


And we're back to square one. I installed the Nvidia driver from their website manually with some help from various sources on how to exactly do it and same black screen of death. X won't start and I don't really get any indications of why. I could change Driver "nvidia" to "nv" in xorg.conf and X would start but I only did this because of things I'd read on various forums and I'm not 100% sure on what the difference was.

And so, due to my addiction to MMORPGs I used Envy to yet again reinstall the driver. I haven't figured out what its doing different from me but its making the same driver, 100.14.19, work when it wouldn't install manually. Xorg.conf does look different from earlier when Envy was used but my original issue is back, slow windows, laggy tabs, etc.

Anyways, I'd be more than happy to post the new xorg.conf from a fresh Envy install if anyone would like to see it. Also I just realized some people might not have any idea what this Envy thing is. Website Its a script/package that automates the process of installing Nvidia and ATI official drivers on Ubuntu (and I think all Debian based distros but don't quote me on that), picking which one and doing the whole process on its own.

almatic 10-08-2007 08:07 AM


I have the same card as you (8800gts with 640mb) and here are some things I know mainly from the nvidia forum (, though I do not know if they are still up to date.

1) the 2d performance of the nvidia driver in general sucks. Although I personally don't find it as dramatic as you describe it, there is notable delay with redrawing windows etc., especially visible if you have desktop widgets active and change to another desktop. Changing tabs in firefox is normal for me however.
The 3d performance, on the other hand, is world-class, that's why beryl seems to have a lot better performance than kwin or metacity.

2) there is a bug in the handling of the graphics memory, when the composite extension is active. As I understood it, used memory is not freed, so as soon as all memory is used, it will give you black windows. Not sure though if that's what you experience, but if you don't use beryl and co., you'd better deactivate the composite extension.

3) For special problems you're probably better off posting them directly in the nvidia support forum at Nvidia has pretty good support, don't forget to make a bug-report with the nvidia bug tool and include it in your post.

linuxboxfun 05-14-2008 12:32 PM

Geforce 8800 Gts - Wth?!?!?
Ok here is the situation...

I have been awaiting patiently for fedora 9 in hopes it would support my 2x geforce 8800 graphic cards. (SLI)

It does not... here are the symptoms...

I go to install the distro "from disk", then it starts the setup... i get through the (test media)

then it gets ready to start the friendly GUI setup/installer, at the bottom of the screen you can see that it knows what video cards are... and RIGHT AT the point of launching the GUI...


I am fairly new to linux, I have gone so far as to get my linux+ certification, and with that said... I am still am at a total loss...

Anybody had this problem?

this problem is the same with both fedora8 werewolf, and fedora9 sulpher.

btw, i have ubuntu on that box, (duel boot xp / ubuntu)

ubuntu's setup was fine

All times are GMT -5. The time now is 04:42 AM.